e-newsletter not working / PHP fatal error

E-Newsletter (2.7.1.8) fails to work. Create / edit pages not loading.
It's not related to php-curl this time. Where do I start ?
Deactivating other plugins doesn't help in this case.
The apache logs shows a time out but nothing really helpful

[Sun Jun 14 19:13:52 2015] [error] [client xxxxxxx] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/wordpress/wp-includes/functions.php on line 4227, referer: http://www....com/wp-admin/admin.php?page=newsletters-dashboard
[Sun Jun 14 19:14:03 2015] [error] [client xxxxxxxx] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/wordpress/wp-content/plugins/wpmudev-updates/update-notifications.php on line 565, referer: http://www....com/wp-admin/admin.php?page=newsletters-dashboard

  • Adam Czajczyk

    Hello @Ifredo,

    I hope you're having a good day!

    The error you're getting explains that the php script is being executed too long and it doesn't complete before reaching the maximum allowed execution time.

    To fix it please try the following steps:

    1. If it's not there, create a php.ini file inside your root install folder and place the following line there:

    max_execution_time = 180

    2. edit your .htaccess file and ad the following line there (somwhere at the beginning)

    php_value max_execution_time 180

    Try the first solution please and if it doesn't work, try the second one.

    Also, you may want to take a look at your server's admin panel first as there's sometimes an option to change PHP settings directly from there. If it's possible, look for "max_execution_time" setting.

    Let me know please if it worked!

    Cheers,
    Adam

  • Ifredo

    Hello Adam,
    Personally I don't think it 's the execution time but the fact that there nothing retrieved from the database. When I extend the execution time, it comes up with a memory allocation error.
    Increasing allowed memory from 64M to 128M doesn't do the trick either.
    PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 304120 bytes) in /var/www/wordpress/wp-includes/functions.php on line 291.
    When I set execution time to 300 seconds and max memory to 256M (just to see what happens...) the call eventually results in a blank page with an xml parser error.
    When the e-newletter works normally it doesn't take that much resource.
    I'll try deinstalling and reinstalling ?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.