Easy Blogging 2.0 beta

Hi gang

Attached to this post is the 2.0 beta of the Easyblogging plugin.

Note: This version is WP3.1 *ONLY* as there are some parts that couldn't be made backwards compatible with the previous version of WP.

Any issues / feedback, please post below.

Thanks
Barry

  • jabbermonkey
    • Flash Drive

    Hello Barry, thanks for the quick Beta...I just installed into the plugins folder.

    I'm using a 3.1 multisite. I had an older version of the plugin installed previously and I was getting a duplicate iframe issue, so I thought I would rejoin WMPU Dev and get the current version....even after the 1.1.2 plugin, I was still getting the duplicate iframe (but it was centered and without the entire left-hand control panel colum). I'm still getting the duplicate iframe issue.

    Here's a screenshot:

  • jabbermonkey
    • Flash Drive

    Hello Barry,

    Thanks for the response and sorry for the delayed reply...had to take my wife out to eat tonight. :slight_smile:

    I uninstalled the old plugin from the mu-plugins directory, then I cleared the cache, then I I just FTP'd the "easybloggingfiles" folder and the easyblogging.php into the Plugins folder, Then I went to Network Admin -> and Network Activated it. Did it twice tonight and I'm getting the same result. This is NOT due to your Beta, but was in fact happening previously. Do you think that I should start to disable ALL my plugins?

    Thanks

  • jabbermonkey
    • Flash Drive

    YEA! Barry, I couldn't be happier! You guys rock! It was either the Google Map widget plugin or just one other that was corrupting (somehow) the script. I deactivated several plugins...long story short - IT WORKS!! No more double IFRAMES and I put the folders in the right place.

    I realized that, unlike the older plugins, you KEEP THE MAIN PLUGIN FOLDER INTACT when you upload it to the Plugins folder. I was opening it up, and sending the one XXX.php file UP and then sending the rest of the folder UP...that's why my CSS files weren't finding each other, etc.

    Hey, you know what. I've been a novice website builder for about 10 years now. I've always loved WordPress, but you all here, at WPMU DEV, really plate WordPress in gold. You developers are good at what you do, and I sure hope that you are happy doing it...because you sure make a lot of people happy with your work.

    Thanks so much for your assistance!

  • jabbermonkey
    • Flash Drive

    Hello, here's a new one....

    I'm towards the end of my MU testing and I add a new user through the sign-up. I select "Just Gimme a Username" and so on.

    After email activation, I sign in and take this new user to the dashboard...and the only thing I see is

    I deactivated all easy blogging, easy blogging quick start guide, easy blogging tooltips, and then the dashboard returned.

    So to check, I reactived just easy blogging and the dashboard disappeared again...any suggestions please?

  • czydrm
    • Design Lord, Child of Thor

    Hey guys,
    I'm hoping that this can be fixed straight away.... with this version of easy blogging activated it removes the WYSIWYG editor buttons.

    Maybe it's a conflict with another plugin but what I do know is that the editors were all good before and after the update, nada.

  • BlueSkies
    • Site Builder, Child of Zeus

    Hi Barry,

    I gave the beta version a good workout with both Firefox 3.5.14 and Internet Explorer 8.

    I found almost the same problem as czydrm. The "New Post" worked fine for me with respect to the WYSISYG buttons. I did see a problem with "New Page" however. Try toggling between Visual and HTML modes on New Page and you should be able to see the problem (buttons disappear in Visual mode). This happened on both browsers and in both Advanced and Easy Admin modes.

    I found one other problem that occurred only on Internet Explorer in Easy Admin mode. From the main blog page, myblog.mydomain.com, click on Dashboard->New Post from the BuddyPress toolbar. For Firefox, the page http://myblog.myblog.com/wp-admin/post-new.php comes up, but is then redirected to http://myblog.myblog.comwp-admin/index.php#post-new-php The layout is fine. Try the same thing in Internet Explorer and the the redirect doesn't occur. The page renders for "Add New Post" but is incorrect. Missing the top row of buttons (New Post, My Posts, etc) and everything above it as well.

    With the older version, 1.1.2, I didn't really see any issues with WordPress 3.1. Is anything broken with that version under WP3.1? It seemed to work better for me than the beta.

    I wanted to also make a suggestion. I noticed that in Easy Admin mode, the BuddyPress toolbar is not visible on the Dashboard. Is this by design? It confused me at first and seems to take the user away from the integration of BuddyPress into the site. Could this be added back in? Maybe make it a setting for the Super Admin to control?

    Scott

  • Ivan
    • The Incredible Code Injector

    Hi Barry,

    I am in a Live Support session with czydrm right now, one thing that I noticed while test driving it is that when a tab is clicked it jumps up and down because of the "#" in the href. This can be fixed with js prevent default. Other than that it looks great ( the href blue is a little bit too much for my taste but that's subjective :slight_smile: ). Great stuff.

  • Ivan
    • The Incredible Code Injector

    Done some more tests and I can confirm that the visual editor disappears.

    Oddly it disappears only when the URL contains "post_type=page" and "index.php?easyadmin=on#page-new-php" respectively for Normal/Easy admin.

  • Timothy
    • Chief Pigeon

    Will the editor issue be resolved on launch, I noticed the lack of buttons also. :slight_smile:

    Also in Edit page whilst enabled it gets rid of the SEO stuff and ads categories and such:

    /wp-admin/edit.php?post_type=page

    (Pages don't have categories and tags, but it shows there)

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.