Easy blogging fatal error

Hey guys,

Does anyone know why I'm getting this error after uploading easy blogging to my mu-plugins folder:

Warning: require_once(easybloggingfiles/easy_blogging.php) [function.require-once]: failed to open stream: No such file or directory in /home/ownablog/public_html/wp-content/mu-plugins/easyblogging.php on line 30

Fatal error: require_once() [function.require]: Failed opening required 'easybloggingfiles/easy_blogging.php' (include_path='.usr/local/php5/lib/php') in /home/ownablog/public_html/wp-content/mu-plugins/easyblogging.php on line 30

Sorry if it's simple, the plugin never came with install instructions