Easy Blogging Update – No Way To Exit Easy Mode

With the latest update, there doesn’t seem to be a way to exit Easy Mode or to log out.

  • Mason
    • DEV MAN’s Sidekick

    Hiya angelopc,

    You’ll need to enable both of these under Network Admin>Easy Blogging. You can show or hide both the logout and ‘force’ the easyblogging mode. Make sure you’re not forcing easy blogging (this way they can exit easy blogging) and that the logout links are marked to be displayed.

    Let us know if you have any further difficulties.

    Thanks!

  • angelopc
    • WPMU DEV Initiate

    Yeah…I guess that would be easy enough, if you haven’t already chosen Activate Easy Mode, as the Admin, with those options already set opposite of what you just said. There is no network.

    If you have Force Easy Mode “On” and Display Log Out set to “Off”, logged-in as the Admin, and you choose Activate Easy Mode, what is the result? What are my options, at that point?

    The only option I have is to deactivate the plugin. Once it’s reactivated, I’m back in Easy Mode. These options should NEVER apply to the Super Admin, right?

  • Mason
    • DEV MAN’s Sidekick

    angelopc,

    Are you on a single install of WordPress? That would explain why you don’t have a Network Admin. As such, you also wouldn’t have a Super Admin user role (that’s also for multisite only).

    Anyway, you should be able to get the settings page back by going here yourdomain.com/wp-admin/admin.php?page=wdeb&settings (make sure the plugin is activated)

    We’ll see about adding a failsafe so that this isn’t possible in the future. You can make the plugin work with anything ya like by activating the “Manage menu items” add on and then creating your own custom menu items.

    Thanks!

  • angelopc
    • WPMU DEV Initiate

    Mason,

    Yes, I know why there’s no Network Admin. Like I said, there’s no “network”.

    Doesn’t the Super-Admin role exist in in every WP installation, regardless of whether it’s multisite or not?

    When accessing EB’s settings, I can see that “Force” is “No”, “Hijack” is “No” and “Always show logout” is “Yes”. The only thing that wasn’t set in my favor was the “Easy bar”.

    I was able to activate the Manage Menu Items add-on and add the custom post type buttons. The odd things is that, after I did that (and adjusted the menu order and items displayed), the Exit Easy Mode and Logout links appear in the Easy Blogging menu (left side).

    Ed

  • Mason
    • DEV MAN’s Sidekick

    Hiya Ed,

    Doesn’t the Super-Admin role exist in in every WP installation, regardless of whether it’s multisite or not?

    Nope. That’s what makes them ‘Super’. They have an elevated role not found on single-site installs.

    Can I get a screenshot of what you’re seeing with the menu items? I’m not sure I’m following on that part.

    Thanks.

  • DavidM
    • DEV MAN’s Mascot

    Hi Ed,

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that’s great news.

    If not, could you let us know by re-opening this topic, and we’ll get onto it and helping you out asap!

    Otherwise, glad you got it sorted :slight_smile:

    Cheers,

    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.