Easy WP SMTP problems

Hi
I've been using Easy WP SMTP for mailing function, with no problems up until now.
For some reason from today it's stopped working, giving me an authentication problem.
It's happening across all my sites, where it used to work fine. I use my GSuite account / SMTP server, and I haven't changed the login details, double checked and they are fine.
Any ideas why this would start failing now?
Thanks, Neil.

  • Nithin
    • Support Wizard

    Hi Neil McEvoy,

    I don't see any common issue reported for Easy WP SMTP plugin in general in their support forums:
    https://wordpress.org/support/plugin/easy-wp-smtp/

    So, it's tough to say what exactly could be causing. Running test emails in the Easy WP SMTP plugin side would also throw any related error which might give a clue. Any such error messages you notice?

    You can also check the debug logs, by enabling debug mode, and see whether it gives any clue regarding what exactly is affecting in the plugin side too.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to run a test to see whether the email works, or not. If not, the releated errors will be saved to a debug.log log file inside the /wp-content/ directory, which you could share to the Easy WP SMTP plugin support, if you think it's an issue specific in the plugin side.

    I hope this brings more clarity. Have a nice day ahead.

    Regards,
    Nithin

  • Neil McEvoy
    • Site Builder, Child of Zeus

    Hi Nithin

    I'm not technical enough to set up the debugging. I've enabled support access if you'd like to take a look.

    Here's the log WP SMTP outputs:

    "CLIENT -> SERVER: EHLO digitalscot.net
    CLIENT -> SERVER: AUTH LOGIN
    CLIENT -> SERVER: bmVpbC5tY2V2b3lAY2xvdWRiZXN0cHJhY3RpY2VzLm5ldA==
    CLIENT -> SERVER: QFJlYWxOZWlsNDc=
    SMTP ERROR: Password command failed: 534-5.7.9 Please log in with your web browser and then try again. Learn more at
    534 5.7.9 https://support.google.com/mail/?p=WebLoginRequired y18sm8835910wmd.29 - gsmtp
    SMTP Error: Could not authenticate.CLIENT -> SERVER: QUIT
    SMTP Error: Could not authenticate."

  • Kris
    • Support

    Hi Neil McEvoy

    Thank you for support access. Your smtp settings looks correct.
    I tested twice (two separate test emails) "WP SMTP -> test email" and outputs works ok:

    CLIENT -> SERVER: AUTH LOGIN
    CLIENT -> SERVER: bmVpbC5tY2V2b3lAY2xvdWRiZXN0cHJhY3RpY2VzLm5ldA==
    CLIENT -> SERVER: QFJlYWxOZWlsNDc=
    CLIENT -> SERVER: MAIL FROM:<***********>
    CLIENT -> SERVER: RCPT TO:<***********>
    CLIENT -> SERVER: DATA
    CLIENT -> SERVER: Date: Mon, 27 May 2019 14:29:24 +0000
    CLIENT -> SERVER: To: ***********
    CLIENT -> SERVER: From: *********** <***********>
    CLIENT -> SERVER: Reply-To: *********** <***********>
    CLIENT -> SERVER: Subject: test
    CLIENT -> SERVER: Message-ID: <***********>
    CLIENT -> SERVER: X-Mailer: PHPMailer 5.2.22 (https://github.com/PHPMailer/PHPMailer)
    CLIENT -> SERVER: MIME-Version: 1.0
    CLIENT -> SERVER: Content-Type: text/plain; charset=UTF-8
    CLIENT -> SERVER:
    CLIENT -> SERVER: ***********
    CLIENT -> SERVER:
    CLIENT -> SERVER: .
    CLIENT -> SERVER: QUIT

    Can you check once again on your side?

    Kind Regards,
    Kris

  • Neil McEvoy
    • Site Builder, Child of Zeus

    Hi Kris

    Yeah it seems to be an up and down problem. I tested it yesterday and it worked fine, but now today it's failing again.

    I'm not sure what to do - Obviously it's essential, I rely on this for all site comms like site registrations etc.

    Neil.

  • Kris
    • Support

    Hi Neil McEvoy
    Can you follow those two solutions and double check does your google account have enabled "Allow less secure apps"?
    https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting#gmail-oauth2-and-allow-less-secure-apps
    https://support.google.com/accounts/answer/6010255

    This was suggest many times on plugin author support page and should solve the issue (as I check your settings there and they look ok)
    https://wordpress.org/support/topic/trouble-with-gmail-setup/#post-10137801

    Kind Regards,
    Kris

  • Neil McEvoy
    • Site Builder, Child of Zeus

    Hi guys
    I am still having ongoing problems with this, it's a real pain.
    Yes Allow less secure apps was set, but it's still failing.
    I'm now trying Sendgrid, who offer a free level for this basic volume of sending, and the set up seemed to go ok and they showed the mail as being sent ok, but I never received it.
    Thanks, Neil.

  • Nithin
    • Support Wizard

    Hi Neil McEvoy,

    Sorry for the delay in getting back to you. From reading the last response in the ticket, you have switched from Gmail to Sendgrid, and still, the emails aren't getting sent?

    We'll have to run further tests on your website since you have now switched the SMTP, seems like support access to your website is not enabled at the moment. Could you please grant support staff access so I can take a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.