Edit Listing Produces A Blank Page

When I try to edit a listing from the my-listing page I get a blank white page with the URL /listings/edit-listing/. This randomly just started happening last week.

I have ran a plugin conflict test as well as a theme conflict test. I am running this plugin on a multi-site network and support access is granted.

I was having a similar issue with this plugin on another site (when I was adding a listing) and the solution was to delete the Virtual pages and reinstall the plugin. However this did not work to fix this issues this time... :slight_frown:

Can someone please take a look for me?

Thanks,
William

  • Vaughan
    • Support/SLS MockingJay

    Hi william,

    Hope you're well?

    Can you check your site error log files, you should be able to find them in your servers CPanel, or look for an error_log file in your seites root folder (Where wp-config.php resides).

    Hopefully there will be something in there which might help us figure out the cause.

    Thanks

  • William
    • Syntax Hero

    Hi @Vaughan

    Here are the latest logs:

    [15-Feb-2016 21:47:40 UTC] WordPress database error Table 'naoia_com.wp_qecta6_places_locator' doesn't exist for query UPDATE wp_qecta6_places_locator SET post_status = 'private' WHERE post_id = 1095 made by do_action_ref_array, call_user_func_array, MS_Model_Plugin->check_membership_status, MS_Model_Relationship->check_membership_status, MS_Model_Communication->save, MS_Model_CustomPostType->save, wp_update_post, wp_insert_post, wp_transition_post_status, do_action('transition_post_status'), call_user_func_array, gmw_pt_filter_transition_post_status

    [15-Feb-2016 23:09:43 UTC] PHP Notice: Undefined index: HTTP_HOST in /home/naoia/naoia.com/wp-content/plugins/domain-mapping/inc/sunrise.php on line 27

    [15-Feb-2016 23:09:43 UTC] PHP Notice: Undefined index: HTTP_HOST in /home/naoia/naoia.com/wp-includes/ms-settings.php on line 35

    [15-Feb-2016 23:09:43 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/naoia/naoia.com/wp-content/plugins/domain-mapping/inc/sunrise.php:27) in /home/naoia/naoia.com/wp-includes/ms-settings.php on line 183

    I'm not seeing anything that stands out, but again I rarely understand the log files anyways lol...

    Support access is granted if you want to jump in and take a look.

    Thanks,
    William

  • William
    • Syntax Hero

    Hi @Vaughan

    I was working to debug another issue on this site and when I disabled the Membership 2 Pro plugin I am able to access the edit screen again. As soon as I re-enable it i get the white page....

    Membership 2 Pro strikes again!!! :slight_frown:

    Please advise on how I should proceed.

    Thanks,
    William

  • William
    • Syntax Hero

    Hi @Vaughan,

    After further testing I fount the blank page was only being generated when editing an existing listing (listings that are already on the website). If I create a new listing I am able to edit that listing without producing a white page.

    I am noticing however when using google chrome if I click the edit button on the newly created listings chrome just refreshes the current page.

    Could you please take a look for me? Support access is granted.

    Thanks,
    William

  • Michael Bissett
    • Recruit

    Hey William, Michael here, apologies for the delay on this one!

    I've tried to reproduce this, but I could use your help for this one, what kind of user are you testing with? I see that there's the "Paid-member" user role now, is that the role you're testing with now?

    I also see that a couple of the pages have changed in the meantime, this page:

    http://myinsurancepage.com/listings/edit-listing/

    Would look to be this now:

    http://myinsurancepage.com/pages/edit-page/

    Also, in case deeper digging's needed for this one (which I get the feeling it will), could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • William
    • Syntax Hero

    Hi @michael55

    I sent off the email! Thanks :slight_smile:

    I see that there's the "Paid-member" user role now, is that the role you're testing with now?

    Yes.

    I also see that a couple of the pages have changed in the meantime

    The page changes you are noticing are correct.

    If you would like to create a free account to test the "Paid-member" user roll that can be done here.

    Thanks,
    William

  • Michael Bissett
    • Recruit

    Hey William, thanks for sending that in! :slight_smile:

    After doing some digging here, the issue turned out to be due to capabilities assigned to the "Paid-member" user role, I've updated the permissions for that role via User Role Editor to include these:

    - delete_agents
    - delete_private_agents
    - delete_published_agents
    - edit_agents
    - edit_private_agents
    - edit_published_agents
    - publish_agents
    - read_private_agents

    And I'm seeing the Edit page work properly for me, no reloads or white screens coming up on my end. Can you confirm the same on yours, please? :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.