Edit Profile Loses First and Last Names In List Of Users

Whenever someone goes in to edit their profile, it shows on the Edit Profile fields, but I lose their First and Last names in the list of Users.

Please see screenshots. The first one shows Edit Profile where I enter display name, first and last names and save them, but second screenshot shows list of Users where First and Last names are blank.

This happens every time someone updates their profile.

Support Access is granted.

  • Sajid
    • DEV MAN’s Sidekick

    Hello Mary,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I could not replicate this issue on your own site. I edited the test user profile and First/Last names saved successfully.

    I updated the profile as admin from Users -> All Users -> Test and edit.

    Do you editing it from front end ? Also, is it a custom user profile form ?

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Mary
    • Wisp of the WP Loop

    I use BuddyPress XProfiles. There is no problem saving from the back end as Admin.

    Please login as User to front end as "test1" with password of *s#$RP5cK5VIBqPNgq3nwHdT (I will delete this user as soon as do this)

    Now make some changes to the profile fields, including First and Last Names and save.

    No go into the backend as Admin Netword -> Users and you will see that there is no First or Last Names saved.

  • Sajid
    • DEV MAN’s Sidekick

    Hello Mary,
    Hope you are doing good today :slight_smile:

    Thanks for providing the test user details in your last reply. I logged in and tried to update the profile but it doe not get save.

    I keep getting following error message, even if I filled all the optional filed too :confused: Also, in front end edit form, I can't see the last name field either.

    Please make sure you fill in all required fields in this profile field group before saving.

    That means, not only First and Last name but also other fields are not being updated/saved.

    It appears to be a plugin/theme conflict or any customization in BuddyPress profile pages broke the update form. So first, make a plugin conflict test and see if you could update the profile.

    Please see flowchart in our getting support manual for how to make a conflict test here:
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.