Edit Tags and Categories within Q&A Plugin

I have a default install of the full Q&A plug-in on my local machine. For questions that I've already created, I'm not able to update/edit/add any new tags or the category. I can go in and edit a question, and the Title and Question will update. However, if I change the category, or attempt to add any new tags, they're not added.

I tried to recreate on your demo site, but I'm not able to create an account to create/edit questions.

  • Mason

    Hiya marketnet1,

    First off, welcome to WPMU DEV! :slight_smile:

    On the Settings page of Q&A you have the ability to set capabilities for each user role. You'll want to make sure that the user role you're currently running has all capabilities.

    Also, what happens when you try to edit, you are just not able to or you edit and on save they are reverted?

    Let us know and we'll continue looking into this with you.

    Thanks!

  • marketnet1

    I have tried this with a couple of different roles. One as an Admin, and have allowed the administrator to have full capabilities. I've also done this while logged in as an Editor, in which I've allowed the following capabilities:

    View questions.
    Ask questions.
    Edit questions.
    Delete questions.
    Subscribe to new questions.
    View answers.
    Add answers.
    Edit answers.
    Delete answers.

    When I try to edit, if I edit every field [title, description, category and tags] the only ones that actually get updated are the title and description. The category and tags revert back to what they were before the update . . as if there was no change.

  • Mason

    Hiya marketnet1,

    Thanks for the detailed explanation. I've tried this out on two separate installs and in each case it's working fine for me.

    I'm wondering what other plugins you have installed? Any caching plugins? Also, can you confirm what versions of Wordpress, multisite, and buddypress you're using if applicable.

    It may also be beneficial to check your server's error logs.

    Apologies for the barrage of questions, but nothing immediately jumps out to me as to why this would happen and want to try to track this down as quickly as possible.

    Thanks!

  • aecnu

    Greetings marketnet1,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.