Editors on my Site See Blank White Screen When they Log In

Hello,

My site (www.golfcoastmagazine.com) is having an issue. When an editor logs in, they see a blank white screen. This is happening to all of my editors and on different computers. This issue does not affect administrators.

I've opened my site for support access.

Can you advise on how I can fix this issue?

Thanks,

Ryan

  • Ash
    • WordPress Hacker

    Hello @Ryan

    Welcome to WPMU community!

    I hope you are doing good and thanks for asking the question :slight_smile:

    Would you please enable debug mode and check if any error is shown in that page?

    To enable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', false);

    to

    define('WP_DEBUG', true);

    Please let us know what errors you see there.

    Have an awesome day!

    Cheers
    Ash

  • Ryan
    • Site Builder, Child of Zeus

    Hello Ash,

    Thanks for responding - good to hear from you, hope that all is well.

    I am receiving the following error in my notices:

    Notice: map_meta_cap was called incorrectly. The post type g1_work is not registered, so it may not be reliable to check the capability "read_post" against a post of that type. Please see Debugging in WordPress for more information. (This message was added in version 4.4.0.) in /*REDACTED* /functions.php on line 3787

    When I log in with my editor account I get a blank screen that shows nothing, including errors.

    I'm not sure if there's somewhere in particular that I should look for debug errors, so I left debug mode on. Can you take a look and let me know how to move forward?

    I've extended support access on my site.

    Thanks,

    Ryan

  • Ash
    • WordPress Hacker

    Hello @Ryan

    I am fine, thanks. I hope you are well too :slight_smile:

    The error you are seeing, seems not to be a significant error. Would you please run a plugin conflict test? Please deactivate all plugins except this one and check if you still face the problem. If not, then enable one by one and check which one is causing the problem. You can see the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let me know what you get.

    Cheers
    Ash

  • Ryan
    • Site Builder, Child of Zeus

    Hello Ash,

    I found out that the conflict was caused by the Aesop Story Engine. Is there any reason why that plugin would cause that problem?

    Also, thank you very much for your help with this issue!

    Thanks,

    Ryan

  • Ash
    • WordPress Hacker

    Hello @Ryan

    I hope you are doing good.

    I have never used Aesop Story Engine, so I am not familiar at all with that I am afraid. But I think you are using one of their theme or addon that deals with roles and capabilities that set some custom capabilities to editor role, so editors could not do anything or seeing white screen.

    I think it will be better if you contact their support team, I believe they will be able to give you an idea about this.

    Have an awesome day!

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.