Either php curl is not installed or HTTPS wrappers are not enabled

[Appointments+] Either php curl is not installed or HTTPS wrappers are not enabled. Login with Google+ will not work.

I updated to the current plugin via the dashboard update. How do I fix this new error?

  • Adam Czajczyk
    • Support Gorilla

    Hello William!

    Please make sure that the line is not commented so it is not

    ;extension=php_openssl.dll

    but

    extension=php_openssl.dll

    Once such a change is made the web server should be restarted. If this doesn't help and you server is Linux/Unix based then if you have shell (command line/SSH) access to it you could issue this command and take a look at its output to check what wrappers are enabled and if HTTPS is among them:

    php -r var_dump(stream_get_wrappers());

    Would it be doable?

    Best regards,
    Adam

  • Predrag Dubajic
    • Support

    Hi Paul,

    Your site doesn't need to use SSL but all calls it makes to the Google+ API must use HTTPS.

    It might be best if you open your own thread for this, even if the issues seem closely related. That way it will remain independent of this one and ensure it doesn't confuse issues here if this thread needs reopening again by the author.

    It also means the member who started this thread or anyone following it isn't inundated with post notifications each time we respond to each other. A lengthy thread could annoy the original poster.
    This also allows us to better track and answer your questions to ensure we don't miss any for you.

    You can start a new thread here:
    https://premium.wpmudev.org/forums/#question

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.