Elegant Themes Compatability

Does anyone know why the Global Footer Content and Footer Content plugins don't work with Elegant Themes?

Also, can anyone suggest a Premium Themes club that works well with WPMUDev, besides your own