Email notifications are not going out.

When i first installed Course Press, the version was 1.2.1.4 and now the version running is 1.2.1.8.

The email notification was working fine with the prior version but now it does not work, i tried various trigger points like: Inviting student/Instructor from (WP->Users->Add New, Course Press Pro->Student/Instructor->Add New), Create account from login window. But it doesnot send the Inviation/notification out.

Could you please help me with this issue. Thanks so much!

  • Tyler Postle
    • CGO

    Hey Heliumlnk,

    Hope you're doing well today and thanks for your question!

    I just tested this out on my own install and the emails seem to be sending as expected for me. Are your other emails sending? For example, when a new user signs up with your site, are you getting the new user email?

    If no emails at all are being sent from your site then it is likely that there is an issue with your server. In which case you would want to contact them OR use an SMTP plugin and switch all your outgoing emails to be sent from elsewhere.

    Here is a good plugin for that: https://wordpress.org/plugins/webriti-smtp-mail/

    Let us know if this helps! Look forward to hearing back.

    All the best,
    Tyler

  • HeliumInk
    • New Recruit

    Thanks Tyler for prompt reply, appreciate it.

    i am using 'WP Mail SMTP' plugin and It works fine with:
    SMTP Host: localhost
    Port : 25

    But, with this the 'From' email ID goes out of my wordpress hosting machine: wordpress@ec2.xxxx
    I have changed the 'From Name' but can i wanted to change the email ID too, so that it goes as my gmail ID.
    i had given following inputs:
    Mailer: SMTP SMTP Host: smtp.gmail.com SMTP Port: 465 Encryption: SSL Authentication: Yes Username: your full gmail address Password: your mail password

    But it failed .... am I doing anything wrong? Thanks.

    Regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.