Emails not sending password to new users when users are added through the dashboard

Hello!

There has been a change in hands in regards to our design team and I am now in charge of our club website. I am having trouble following the work of the last designer and can't seem to figure out why the user name and password are not sent to new members that are added through the dashboard. I checked the box which asks that a password to be sent to the new user (see screenshot). What am I doing wrong?

  • Vinod Dalvi
    • WP Unicorn

    Hi @Pdca Admin,

    Sorry to hear of the problem you are having.

    Are you using single WordPress site?

    Are you getting any emails from your site?

    Could you please install, configure the following plugin and try sending test email and let me know whether you get it or not?

    https://wordpress.org/plugins/easy-wp-smtp/

    This can also be due to theme/plugin conflict.

    You can just try on your development site deactivating all other plugins and using default WordPress theme like Twenty Thirteen as displayed in the flowchart on the following page to know which theme/ plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Kind Regards,
    Vinod Dalvi

  • Pdca Admin
    • Site Builder, Child of Zeus

    Thank you for your quick response!

    Yes, this is a single WordPress site.

    This is the first time I have used the email function so I am not sure if other emails are sending. I will install and configure the plugin you sent me right now.

    I would be more than happy to give you access to our site.

    I installed the WPMU Dev Dashboard plugin and activated it. When I went to login to the plugin I received this message:

    Your server had a problem connecting to WPMU DEV: "Failed to connect to 190.93.245.12: Permission denied" Please try again.
    If this problem continues, please contact your host and ask:
    "Is php on my server properly configured to be able to contact https://premium.wpmudev.org/wdp-un.php with a GET HTTP request via fsockopen or CURL?"

  • Pdca Admin
    • Site Builder, Child of Zeus

    I installed the plugin and set it up. I made a test account and asked that an email be sent to the user. It has been 15 minutes and I do not see an email. Either the previous designer did not set this up correctly or I am doing something wrong. Thank you for your help tonight.

  • Jack Kitterhing
    • Code Norris

    Hi there @Pdca Admin,

    Hope you're well today and thanks for the additional information.

    Sounds like this is all mostly related to hosting configurations possibly, could you send me the following to take a look at this for you?

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

  • Pdca Admin
    • Site Builder, Child of Zeus

    Hello!

    Good news. The WPMU Dev plugin is now connecting to the WPMU Dev server. I am logged in through the plugin and will send the information you have requested.

    Emails related to user accounts, login and passwords are still not sending. Also, the login box "Registration" link is redirecting to the generic registration form built into WordPress rather than the custom one that comes with the Membership plugin.

    I will open a trouble ticket with the hosting company and see if they can look around and find anything. You are also welcome to look around. Please check the concerns listed above and also check why the login box (configured through the Membership plugin widget) is redirecting away from the custom 'Registration" link when the box to enable it is checked.

    I will set up an admin account for WPMU Dev staff and will include that in my support ticket.

    Thanks again!
    Amber

  • Jack Kitterhing
    • Code Norris

    Hi there Amber,

    Hope you're well today! :slight_smile:

    That's great news! Glad to hear that it's now working with the dashboard, the support staff login ends up redirecting to the login page, so I haven't been able to access it yet, as the other information hasn't come through.

    Could you let me know which email that was sent with please? It doesn't seem to be the one attached to your account here. :slight_smile:

    Also, the login box "Registration" link is redirecting to the generic registration form built into WordPress rather than the custom one that comes with the Membership plugin.

    Is that the registration link on wp-login.php? That's correct. :slight_smile: The actual WordPress registration system should be disabled in wp-admin > settings > general.

    Uncheck the "Anyone can register" box. :slight_smile:

    Please advise.

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.