emails won't send

I setup the plugin and things appear correct. I formatted an email for a small test group. I clicked to send the email. Nothing happened. I can send a test email just fine. I receive no error messages of any kind from the plugin. Here is what the dashboard currently says:

Sent - 0
Waiting - 7
Cron (disabled) - 5

My settings for the plugin are:

SMTP settings
Limit send (cron) - blank
Emails per (cron) - 1 hour ** I have tried this set on never and on 1 hour with no difference in behavior.

Do I need to do something else to get these emails to send? I don't see anything in the documentation besides how to install the plugin.

Thanks for your help.

Blessings,
Wendy

  • Mason

    Hiya Wendy,

    From the e-newsletter dashboard do you see Cron as disabled? If so, you should definitely have the SMTP outgoing setting to 'Never'.

    When you click Send, you should be sent to a page where you can decide which members receive the message and then have a progress bar showing the process of each mail being sent. Are you seeing this? Does it appear to complete?

    You mentioned no errors - does this include js errors in the browser?

    Let us know. We'll take a look deeper with ya.

    Thanks!

  • Wendy Merritt

    Here is what my outgoing email settings are:

    Email Sending Method: X SMTP (recommended)
    SMTP Outgoing Server: ssl://smtp.ferrisbaptistfellowship.org:465 (eg: ssl://smtp.gmail.com:465)
    SMTP Username: newsletter@ferrisbaptistfellowship.org (leave blank for none)
    SMTP Password: ************ (leave blank for none)
    Limit send: (CRON) (0 or blank for unlimited)
    Emails per (CRON) 1 hour ('Never' - not use CRON for sending emails)

    When I try to send the message:

    I select All Members
    I click Add Newsletter to CRON list button
    The previous sending: now displays 6 waiting send

    Over an hour later...the Newsletter Dashboard says:
    Newsletters 1
    Members 6
    Groups 2
    Sent 0
    Waiting 13
    CRON (disabled) 11

    What do I try now? Thanks for your help.

    Wendy :slight_smile:

  • Wendy Merritt

    AHA! I got it!
    I had to change this:

    SMTP Outgoing Server: ssl://mail.ferrisbaptistfellowship.org:465 (eg: ssl://smtp.gmail.com:465)

    then I changed the outgoing settings to:

    Emails per (CRON): Never ('Never'-not use CRON for sending emails)

    Those two changes released my email. Do I need to worry about the emails that are stuck in limbo? My Newsletter Dashboard still reads:

    Newsletters 1
    Members 6
    Groups 2
    Sent 6
    Waiting 13
    CRON (disabled) 11

    Thanks for your help.

    Wendy :slight_smile:

  • Mason

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.