Embed video into WPMU page or post

When I add the embed video code you've provided, nothing happen, it does not seem to work. I'm using WPMU, can you please advise?

<object width="640" height="405"> <param name="movie" value="http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/bootstrap.swf"></param> <param name="quality" value="high"></param> <param name="bgcolor" value="#FFFFFF"></param> <param name="flashVars" value="thumb=http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/FirstFrame.jpg&containerwidth=640&containerheight=405&content=http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/1media.swf"></param> <param name="allowFullScreen" value="true"></param> <param name="scale" value="showall"></param> <param name="allowScriptAccess" value="always"></param> <param name="base" value="http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/"></param> <embed src="http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/bootstrap.swf" quality="high" bgcolor="#FFFFFF" width="640" height="405" type="application/x-shockwave-flash" allowScriptAccess="always" flashVars="thumb=http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/FirstFrame.jpg&containerwidth=640&containerheight=405&content=http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/1media.swf" allowFullScreen="true" base="http://content.screencast.com/users/Farms/folders/Default/media/f815575e-dbdc-40c7-850e-93b2de8647a9/" scale="showall"></embed> </object>