Embedded Video is Shorter than Normal

I am not sure why embedded video frame is not same as original dimensions. See screenshot

  • Le
    • WPMU DEV Initiate

    Hi, its is Youtube video and I just paste embedded code to the Unit Text element. It is funny that the editor does not have Visual & Text tab.

    I tried Video element & upload it but video does not play.

  • Le
    • WPMU DEV Initiate

    Hey, is there option to use the core wordpress editor in the course content editor? If yes I think can fix the issue easily, also many people use additional video player, plugin that use shortcode. So supporting core editor in course content editor is perfect.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Le!

    Right now, CoursePress doesn't have an option to use the default WP text editor.

    I think we can work around this, however. Instead of using the embed code, try to just insert the sharing link, instead. (Check out my screenshot from YouTube, below.)

    Second - is the video perspective distorted on the front end of your site, as well as in the text editor? There's a chance it may display properly on the front end, within your theme.

    Third - we can try a little CSS to bring it back into shape, would it be possible to share a link with us to a course page with an embedded video on it so we can make sure to get the selectors right?

    Thanks, Le!

  • Le
    • WPMU DEV Initiate

    Hi Michelle,

    I preview the unit and the video still distorted, add a direct youtube link to the text unit it appear blank at the front end.

    The course it not live yet so I not able to share the link. If you can make default Wordpress Editor in to the course, that is best because we not only need the video to display, we also need the put embedded codes and short codes from other video tracking like Wistia, PressPlay...

  • Tyler Postle
    • CGO

    Hey Le,

    Hope you're doing well today and thanks for the screenshot!

    I pasted some embed code into a text element and the video displayed fine. I used this:

    <iframe width="560" height="315" src="//www.youtube.com/embed/LaP1H-JJroU" frameborder="0" allowfullscreen></iframe>

    Are you setting the width and height?

    Do you mind granting support access so we can take a look at your course setup? Or if you can just paste your video link for us so we can try it with your video :slight_smile:

    Look forward to hearing back Le!

    All the best,
    Tyler

  • Le
    • WPMU DEV Initiate

    Just to update, no more problem with the new version of coursepress. However there is another issue: The "Course Structure" outline only appear for the free course, the paid course does not appear at all.

  • aristath
    • Recruit

    Hello there @Le, I hope you're well today!

    Could you please grant us access to your backend so that we may see exactly what is happening?
    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the "Grant access" button.

    Please note that you must have the WPMU DEV Dashboard plugin installed on your site to complete the above process.

    Also, in the future please avoid posting multiple issues on the same thread.
    Since your original post with the video size has been resolved this should be a different thread.

    Cheers,
    Ari.

    • Le
      • WPMU DEV Initiate

      You can look into the basic set up course in the site, from the front end you will see it looks good, all units are listed. But of you go to the back end, there are more than 1 page in each unit, but front end show only the first page of each unit.

  • Tyler Postle
    • CGO

    Hey Le,

    Hope you're doing well today!

    This is very odd, on my installation it shows all pages within a unit as expected - then you can select each page to be available or not for the free preview.

    I've attached a screenshot to illustrate what it should look like.

    Do you mind deactivating all your other plugins and seeing if it works correctly then? This is to ensure it isn't a plugin conflict.

    If that doesn't work then do you mind turning on your WP_DEBUG in your wp-config.php file and seeing if any errors come up :slight_smile:

    You can turn that on by setting this line:

    define( 'WP_DEBUG', false );

    To:

    define( 'WP_DEBUG', true );

    Then navigate to your course setup page and see if any errors/warnings/notices come up.

    Look forward to hearing back Le! If you need any assistance doing this then just let us know.

    All the best,
    Tyler

  • Michelle Shull
    • DEV MAN’s Apprentice

    Thanks for running that test, Le!

    Did you also try de-activating your other plugins to see if one of them may be causing this issue with CoursePress, as Tyler suggested? We've ruled out a lot of other possibilities, a plugin conflict seems like the most likely cause at this point.

    After you've de-activated them, try turning them back on one-by-one until you find the one that's interfering with how your pages are displaying on the admin side of your site.

    Thanks, Le!

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Le!

    I've got a few more things to try. :slight_smile:

    1. Let's try a fresh install of CoursePress. Deactivate and delete the current copy first, then install a new copy. All your course data will be stored in the database, and it will show up once you've activated your new copy of CoursePress.
    2. After you activate CoursePress, re-save your permalinks, just in case.

    After this, if we're still not getting anywhere, we'll call in more help, but let's give this a go first.

    Thanks for all your patience and great testing here, Le! We really appreciate you working with us. : )

  • Tyler Postle
    • CGO

    Hey Le,

    Hope you're doing well today and thanks for your reply!

    That shouldn't be causing this issue. Looks to be just a warning or notice.

    Do you mind sending in your FTP and WP login credentials privately through our contact form so we can take a closer look here? :slight_smile:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Look forward to hearing back!

    All the best,
    Tyler

  • Tyler Postle
    • CGO

    Hey Le,

    Hope you're doing well today! Thanks for all your patience.

    I managed to reproduce this on my install. It seems kind of random to me so far, once it happened when I added 3 pages and the next time when I added 2 pages. I'm flagging it as a bug so our developer can get this sorted :slight_smile:

    Once it is fixed either myself or the developer will post back here.

    Enjoy the rest of your weekend!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.