Embedding YouTube link in course unit of coursepress pro

Hi I am trying to add a new unit to a course on coursepress pro. As the instructions says, I copy embedded link from YouTube to the box in the course unit.
When I say save and then preview, it shows the same embed link on the course page but does not load the video. Can you please help.
Thanks, Atul

  • Milan

    Hello Atul,

    I hope you are having a good day and thanks for asking. :slight_smile:

    I can't replicate issue on my sandbox site. I've tried both text and video element of unit editor. Both are displaying video link without any issue.

    Dear Atul, if you are using video element of unit editor to embed youtube videos, then please use video's original link which you see in your browser address bar while viewing video. For more information please see attached screenshots.

    And if you are using simple text element of unit editor to render video along with text, then you can use embed video link in it. It should work fine.

    If you are already doing what I told you above, then Would you please grant me support staff access so that I can check in depth regarding your issue ?. You can grant me support access via WPMU DEV > Support > Support Access > Grant Access.

    Let me know once you enable support staff access.

    Thanks for being with us. :slight_smile:

    Best Regards,
    Milan Savaliya.

  • Milan

    Hello Atul,

    Your most welcome. :slight_smile:

    If I won't be able to access your site then it will be very difficult for both of us to track issue fast, I am not saying its not possible just little time consuming. :slight_smile:

    So first let me help you to solve your first issue regarding WPMU DEV Dashboard. From the error perspective it seems to me that its issue with your host, may be curl or fsockopen extension is not enabled so first step to solve this is asking your hosting provider this question.

    Is php on my server properly configured to be able to contact https://premium.wpmudev.org/wdp-un.php with a GET HTTP request via fsockopen or CURL?"

    Let see what they got for you first. If they say you everything is properly setup and issue is at our end, then I suggest you wipe out older installation of WPMU DEV Dashboard, and install latest plugin via ftp. You can download latest release from here,
    https://premium.wpmudev.org/project/wpmu-dev-dashboard/

    If above steps don't solve your issue, then I suggest you issue new thread on our Support portal for this. Once you issue thread, one of our staff member will get back to you as soon as possible.

    Now let me move on to our main issue, regarding Course-press unit's video element is not embedding youtube videos properly.

    I can see you are using twentyforteen theme with Coursepress so to be sure its not issue with theme I've quickly changed my theme and test with twentyfifteen theme, everything worked fine with it too.

    So second guess is plugin conflict. Can you please conduct quick plugin conflict test as described as flowchart on our support manual page here , ?
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Looking forward to hearing back from you Atul. :slight_smile:

    Best Regards,
    Milan Savaliya.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.