Emergency! Please help!

I really fucked up my website. I was installing a new theme, and in the settings changed my homepage name (i added a home extension thinking that would link to my temp home page) NOW I CAN'T LOG IN TO THE ADMIN AREA TO FIX IT!!! I'm such a fucking idiot!!!!

If anyone can tell me how to fix this, here is the web address:

http://www.teachingyourselfspanish.com

Thanks in advance.

  • aristath
    • Recruit

    Hello there @scottshell, I hope you're well today!

    You mentioned that this was caused by your new theme.

    You could try deleting your theme from /wp-content/themes (or simply move it to another folder, somewhere other than the themes folder as a temporary solution).

    Please try that and if it doesn't work post back here.

    Cheers,
    Ari.

  • aristath
    • Recruit

    Try this:

    Open your database using phpmyadmin or whatever else you have access to.

    Now, depending on what you changed, you'll have to edit one of the following:
    On the wp_options table, the "home" row (just look for a setting with that name)
    Or if you simply selected an invalid page, look for a setting with the name "page_on_front".
    Edit its value to a number like 1,2,3 etc.

    I hope that helps...

    Cheers,
    Ari.

  • Ollie
    • The Incredible Code Injector

    and if the above doesn't fix it, then try the following in phpmyadmin

    wp_options > active_plugins > edit

    Replace values with a:0:{} and save it.

    You'll need to re-enable to plugins again one by one but it might get your site back to continue troubleshooting.

    Cheers
    Billy

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.