Empty thumbnails (?)

Hello,
I am searching for a solution to fix this problem. The site is not using the multi blog system. Although I set the featured image for each post, yet it shows in the front page as a an empty frame with the name of the post.
Is there a way to fix this issue?
Regards!

  • aecnu

    Greetings :slight_smile:

    I am having the same issue with this theme too.

    Using WPMU 3.1.2

    Though I have a regular image in the post and a Feature image I get an empty square box with an "x" in it for missing image.

    When I check the image properties it gives:
    http://online-outlet-shopping-center.com/wp-content/themes/network/library/functions/timthumb

    Though all my posts have images none of them show if I choose network or blog posts within the theme.

    Furthermore after some investigation it is my opinion it has something to do with TimThumb that seems to be incorporated within the Theme.

    From what I have read about TimThumb here on WPMU DEV - it is trouble.

    Furthermore, within the TimThumb version that comes with the theme the Multisite version is set to False. I changed it to true, I permission-ed the file to 777, I also made sure the blogs.dir was set to 777 so it could write the so called /cache directory within as is written in the script ..... all to no avail.

    In my opinion this theme needs the portion that deals with TimThumb re-written to deal with featured image instead.

    I admit I am super disappointed with this one because I have this theme marked for two network sites and I have spent a couple of hours trying to fix it to no avail.

    Joe :slight_smile:

  • Tammie

    It works in all my testing for my setups as said before. I therefore need the following from each of you:

    1. Does it not work with ALL plugins off
    2. Have you made sure on latest version
    3. Please provide a link

    I understand being disappointed but we do not release something that doesn't work and this has worked in our tests. Therefore we need to look at why does not work for currently 2 of you (2 is actually a small number that use the theme) and take from there.

  • aecnu

    Greetings Tammie :slight_smile:

    thank you for your reply and sorry for the delay while I worked on other projects and the site this theme was on was a production site that I could not shut down or turn all the plugins off.

    I would like to mention I am using WP 3.1.2 and the Twenty Ten Theme on the sub-site - and your Network Theme works flawlessly.

    In addition, I have an image inserted at the top of the post and also the same as the featured image :slight_smile:

    Not for a minute do I think you folks would release something that does not work ..... the support hassle would certainly not be worth the trouble :-S

    I was just looking for the missing reason that was causing the problem - which I still do not know what it was but that is my problem :slight_smile:

    I will keep an eye on it and let you know if I figure it out :slight_smile:

    Thank you for your patience and sticking to your guns :slight_smile:

    Joe :slight_smile:

  • abdulazizm

    Dear David,

    I am still facing the same issue although all of the plugins are deactivated- other than Buddypress.
    When I right click on the empty box and open the link in a new window it gives me this error:
    "
    Warning: parse_url(/wp-contenthttp://www.themedan.com/wp-content/uploads/2011/04/IMG_5403.jpg) [function.parse-url]: Unable to parse URL in /home3/themeda1/public_html/wp-content/themes/network/library/functions/timthumb.php on line 576

    Warning: Cannot modify header information - headers already sent by (output started at /home3/themeda1/public_html/wp-content/themes/network/library/functions/timthumb.php:576) in /home3/themeda1/public_html/wp-content/themes/network/library/functions/timthumb.php on line 770
    remote host "" not allowed
    Query String : src=http://www.themedan.com/wp-contenthttp://www.themedan.com/wp-content/uploads/2011/04/IMG_5403.jpg&h=108&w=227&zc=1&multisite=false&blogdirid=1
    TimThumb version : 1.19"

    Any idea?
    Thank you for your support!

  • Tammie

    Still need confirmation you are on the latest version of Network as unless David isn't telling me something and he can recreate this.. I can't recreate it in my tests.

    Therefore I still need that confirmation before looking. Also can you make sure you try the following incase something 'caught'.

    1. Remove the theme and ALL files
    2. Put on Twenty-ten / BuddyPress default theme - up to you which
    3. Get new files and upload these again please in entirety onto your site.

    Then we can be sure you are on the latest version.

    If after that you still have issue please let me know here ALL your theme option settings you've set for the theme so can test offsite with those. Also let us know if a sub site / main site.. what your set up is.

  • Tammie

    We have a user called Herman Scott-Dahl who came up with a patch that works in his case.

    This may or may not help you however posting incase it does and you are still experiencing it.

    Solved the problem. I had to change

    if ($multisite == "true" && $blogdirid > 0) {

    on line 23 in /wp-content/themes/network/library/functions/timthumb.php to

    if ($multisite == "false" && $blogdirid > 0) {

    in my child theme. Then I used the child theme on the main blog, and it worked. I'm not sure why I needed and do this, but found that it could be an opportunity after changing some parts of the imageurl in my web browser.

    I just for now want to see if those users experiencing this gain from this fix temporarily. We will be looking to do a more permanent fix.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.