enable browser caching

I cannot seem to enable browser caching... I see the settings... set them accordingly... it then says the code snippet has been updated... but then none of the settings seem to be set... it's as if it has not been enabled at all...

Thank you for you assistance and reply...
Sheldon