enable BROWSER CACHING page loads and says NGINX server settings

I have Apache and cpanel cloudflare installed
when activating BROWSER CACHING it says

For NGINX servers:
Copy the generated code into your nginx.conf usually located at /etc/nginx/nginx.conf or /usr/local/nginx/conf/nginx.conf
Add the code above to the http section in the file.
Reload NGINX.
If you do not have access to your NGINX config files you will need to contact your hosting provider to make these changes.
Still having trouble? Open a support ticket.
location ~* \.(txt|xml|js|css)$ {
expires 8d;
}

location ~* \.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$ {
expires 8d;
}

location ~* \.(jpg|jpeg|png|gif|swf|webp)$ {
expires 8d;
}

I have no control of cloudflare NGINX config
I change it to Apache and it asks me
WP Hummingbird will try to write into your .htaccess file for you
I do and at the top it say
Browser cache enabled. Your .htaccess file has been updated
You might want to put a note or default it to what ever the server is running.
Just my 2 cents.
you can close this after viewing and if its valid make a suggestion to the developer
thanks