Enabled SSL, See lock if I remove header image. Want the lock to show…

Hello.

I have enabled SSL but couldn’t get the lock to display on our website. I ran a test and saw that our header image was not valid to be secured and was the only thing limiting it. The logo is displayed from our theme’s control panel. When I remove the logo, the lock appears on my website which is what we want.

However, we also need our logo. Any way to get this to pass?

http://cityofhanahan.com

Thanks in advance,

David

  • Nithin
    • Support Wizard

    Hi David,

    Hope you are doing good today. :slight_smile:

    However, we also need our logo. Any way to get this to pass?

    Since I don’t see you mention about it, did you try editing the url image, and then try saving it in your theme panel?

    You are only having issues with one image, and the image is added through the themes control panel, the simplest method is to edit the url, to https, and save it.

    ie

    https://example.com/logo.png

    if that didn’t work, try adding the url as:

    //example.com/logo.png</strong>

    If you still have problems with the above, please enable support access, so that we could give a closer look, on how the image is implemented. Have a nice weekend. :slight_smile:

    Kind Regards,

    Nithin

  • David
    • The Crimson Coder

    Hello Nithin,

    So the theme options page is a GUI with no bar to directly input a link. I was going to try that but it only has the option to upload a new image or change the image.

    I can hard code it in and eliminate the Theme Option I suppose.

  • Kasia Swiderska
    • Support nomad

    Hello David,

    There is this plugin https://pl.wordpress.org/plugins/ssl-insecure-content-fixer/ that helps with mixed content problem. Please give it a try and see if it can help on your site.

    I can hard code it in and eliminate the Theme Option I suppose.

    That could be also solution, but if you still want to update your theme remember to do those type of changes in Child themes https://codex.wordpress.org/Child_Themes

    kind regards,

    Kasia

  • David
    • The Crimson Coder

    Kasia,

    Good afternoon. This did not correct the issue with the header image (logo) displaying as a non-secure item. I have enabled support for my others open ticket, if you would like to take a look at this as well.

    I don’t see a workaround for it, but perhaps I’m overlooking something. Hard-coding may be the only option here.

  • Rupok
    • Support Ninja

    Hi David,

    Thanks for granting Support Access. I logged in and found, your site configuration is still using "http" instead of "https" in WordPress Address and Site Address URL settings in "Dashboard > Settings > General" section. Please check the attached screenshot for reference.

    Can you please change those links from "http" to "https" and save? I believe, your theme header or option page has called relative URL for the logo image and using the address defined for site before the logo path. So changing this might solve your issue.

    Can you please try this and let us know if it works? If it doesn't, please let us know. We will be glad to assist further.

    Have a nice day. Cheers!

    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.