enabling Gzip compression

I've just installed Hummingbird plugin. Somehow the plugin is set to manual rather than automatic and I can't seem to enable the feature.