enabling network: Because your install is not new, the sites in your WordPress network must use sub-

doing a fresh install of wp. enabled Network in tools (modified wp-config.php) but when I go to setup my network I get:

Because your install is not new, the sites in your WordPress network must use sub-domains.

I cannot use sub-domains due to host limitations and want to use directories instead. Why does it say my install is not new? is there a certain order of doing things or a flag I have to clear somewhere?

  • aws
    • WPMU DEV Initiate

    found it:

    sharing on how you can remove WordPress Multisite data completely incase you don’t want it or you want to re-install with a fresh state or whatever.

    * Remove all the lines added to wp-config.php
    * Revert back to older .htaccess file or delete it and regenrate it by going to Settings > Permalinks
    * Remove the two fields added to the users table that are multisite-only (deleted and spam columns).
    * Remove the following tables in database (prefixed by your DB prefix which is generally wp_):
    o wp_blogs
    o wp_blog_versions
    o wp_registration_log
    o wp_site
    o wp_sitemeta
    o wp_signups
    o wp_sitecategories (if you have global terms enabled)

  • drmike
    • DEV MAN’s Mascot

    There's a 30 day check for some reason when converting. I've not seen a real reason why but Andrea's talked a couple of times how to override that on the wp.org forums.

    Gotta break the links to get the quotes to show up:

    google.com/search?q=site%3Awordpress.org%2Fsupport+"Because+your+install+is+not+new"

  • exberry
    • The Incredible Code Injector

    Here we are over a year later than the original post above ... and I just ran into the same problem.

    I am posting this to say thanks to @hiuuf for providing the solution.

    I set up a whole new account, transferred in a domain, and installed WP. No problem. Then I added
    define(‘WP_ALLOW_MULTISITE’, true);
    as per instructions.
    I go to Network Setup and find the same message as above. I deleted WP and reinstalled 3 times but still had same problem. I tried regenerating .htaccess, but this did not allow me to use sub-directories.

    Then I tried the suggestion of @hiuuf and it solved the problem.

    Thanks, @hiuuf.

    Ed

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.