Enabling the Import Feature in CustomPress

Hi there,

Hope you can help. I’m a novice so please go easy. :slight_smile:

Using the instructions at the bottom of the Export/Import section of CustomPress – I’m attempting to enable the import feature, in order to import a custom post type, created using ACF.

However, I’m unsure where to paste the code; define(‘CT_ALLOW_IMPORT’, true); in the wp-config.php file

Many thanks!

  • Dimitris
    • Support Star

    Hey there Nate,

    hope you're doing good and thanks for reaching us! :slight_smile:

    This line should be put just above the /* That's all, stop editing! Happy blogging. */ comment. See next screenshot.

    In order to edit the wp-config.php file, you should access your server through FTP, or a "File Manager" via your server's control panel (cPanel, Plesk etc.)

    Hope that was some help, feel free to post back here if more assistance is required and we'd be more than happy to further help you out! :slight_smile:

    Warm regards,

    Dimitris

  • Nate
    • WPMU DEV Initiate

    Thanks for the speedy follow-up Dimitris.

    I followed your instructions and updated the wp-config.php file using Filezilla FTP however I see no change in CustomPress. Should expect changes to propagate immediately or is there usually a delay?

    FYI – I’m using GoDaddy’s WordPress Hosting product.

    * obito https://codex.wordpress.org/Debugging_in_WordPress
    */
    define('WP_DEBUG', false);
    //define( 'WP_CACHE', true );
    require_once( dirname( __FILE__ ) . '/gd-config.php' );
    define( 'FS_METHOD', 'direct');
    define('FS_CHMOD_DIR', (0705 & ~ umask()));
    define('FS_CHMOD_FILE', (0604 & ~ umask()));

    define('CT_ALLOW_IMPORT', true);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  • Dimitris
    • Support Star

    Hello Nate,

    you shouldn't experience any latency on this… :thinking:

    Could you please try to clear any caches involving to your installation (plugins, server-side services, 3rd party providers like CloudFlare) and give it another try?

    You should have been able to have a region to paste your previously exported code now (as my screenshot below)

    Warm regards,

    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.