Enabling Ultimate Branding Plugin Modules redirects to the wrong location

Enabling or disabling an individual (or all) Ultimate Branding Modules redirects to the wrong location:
http://www.mysite.ca/wp-admin

Should be:
http://www.mysite.ca/wp-admin/admin.php?page=branding

Users should not need to navigate to the branding page 5 times if they want to enable 5 modules!

Steven