Encountered HTTP500 after upgrading to 2.0.5

Got 1 problem: deactivate 2.0.4, upgrade to 2.0.5, activate, then HTTP500, what could possibly the cause of this? No error log generated from php.

Got a question: where to activate the terms for user to agree before subscribing?