Encountered HTTP500 after upgrading to 2.0.5

Got 1 problem: deactivate 2.0.4, upgrade to 2.0.5, activate, then HTTP500, what could possibly the cause of this? No error log generated from php.

Got a question: where to activate the terms for user to agree before subscribing?

  • Shean
    • Design Lord, Child of Thor

    Finally it spits out error as follow:

    [29-May-2011 00:24:46] PHP Warning:  require_once(membershipincludes/includes/membership-config.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home/sandbox/public_html/bmi/wp-content/plugins/membership/membershippremium.php on line 29
    [29-May-2011 00:24:46] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'membershipincludes/includes/membership-config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sandbox/public_html/wp-content/plugins/membership/membershippremium.php on line 29

    I've checked and tried deleting/reuploading several times, still problem with HTTP500 error when accessing wp-admin, but the front-end is ok. Files that it claimed cannot be found or failed to open are there, and did vi, it opens fine.

  • Shean
    • Design Lord, Child of Thor

    Wordpress 3.1.3 on CentOS (Kernel 2.6.18-238.9.1.el5) with cpanel 1.0 (RC1).
    Apache version 2.2.15
    PHP version 5.2.13
    MySQL version 5.0.91-community

    Hope this helps. Let me know if you need more. There are no other special configuration, and I already testing with bare configuration and twentyten theme.

  • Shean
    • Design Lord, Child of Thor

    Thank you for taking the time to look into it. I wonder if there is anyway on how session was handled, and how it stored its upgrade info? I've had some difficulties of such previously, but nothing unresolvable as long as I start with a new installation. Somehow not this time.

  • Shean
    • Design Lord, Child of Thor

    FYI, just a hunch, so I downloaded a lite membership, removed the premium version, then activate. Viola, it works now. Yet, when I deactivate, deleted the lite, upload the premium, tried to activate, 500 error appeared.

  • DavidM
    • DEV MAN’s Mascot

    Hiya Shean, thanks for providing all the extra information. This one's an odd circumstance so all the added info helps.

    That said, there's been an update (version 2.0.6) that I believe addresses this particular issue, could you give that a try?

    Thanks,
    David

  • Shean
    • Design Lord, Child of Thor

    Tried v2.0.6, same problem. Only the lite version works.
    This time, I turned on WP_DEBUG, and the following error appeared when membership premium enabled:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/sandbox/wp-admin/includes/menu.php on line 176

    I'm going on a trip for a few weeks, can only access email, so temporarily suspend this subscription. I'm not sure if I can post via email, or else, will find a way to submit any further findings.

  • DavidM
    • DEV MAN’s Mascot

    Hmm, that is odd. I can imagine the script taking up a lot of memory if there's a lot of users to account for but not if it's just a sandbox with a small number of users.

    Given that the bump in memory seems to resolve it, if you're still concerned about this, could you let us know what plugins you have running alongside it?

    Thanks,
    David

  • Shean
    • Design Lord, Child of Thor

    Plugins running with it are:
    - nextgen gallery
    - wordtube
    - user messages
    - akismet

    Previously running fine on your older version. Then the upgrade caused the problem. No additional plugins ever added since.

  • Shean
    • Design Lord, Child of Thor

    Just upgraded to WP 3.2, and here is the error:
    PHP Fatal error: Call to undefined method WP_User::WP_User() in /home/sandbox/html/wp-content/plugins/membership/membershipincludes/classes/class.membership.php on line 23

    Any idea why this happened?

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    As we haven't heard back from you we're going to assume the problem
    was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this
    thread please feel free to post them below and tick the 'Mark as Not
    Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU
    DEV, it's a pleasure to help you out and we look forward to being of
    assistance in the future.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.