Encountering some problems with Multisite, having issue displaying my website

From the administration page at Wordpress when clicking on, visit site, http://www.freehuckleberryads.com it takes me to our site displaying the header page with the all our tabs. I definitely am left with a head scratcher. It says we are already a member of this site, in the box it says, freehuckleberryadscom with the .freehuckleberryads.com under the box, has a couple of other boxes yet to be filled in, and appears to have a conflict at the bottom of the page with url/home definitions. I have attached a snippet (freehuckleberryads.com.png).

When typing in either freehuckleberryads.com or http://www.freehuckleberryads.com It also says we need to log in? . Don’t understand why we have to log in to view our website? Never had a problem with our single site install of Wordpress before but somewhere I must be overlooking something in the settings?

Help in this matter would be appreciated.

Thank you
Doug

  • Huckleberry Press
    • WPMU DEV Initiate

    Hi Jack,

    Didn't know if my attachment worked saw denied extension so I copied the code here from the file.

    # Use PHP5.4 as default
    AddHandler application/x-httpd-php54 .php

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # END WordPress

    Thank you.
    Doug

  • Huckleberry Press
    • WPMU DEV Initiate

    Hi Jack,

    Referring back you my first response to you in regard to the www. I did this in the wp_config.php file where the domain referred to it as http://www.freehuckleberryads.com . This line was in the lines the multisite I added for multisite. The first time I removed the www just leaving the freehuckleberryads.com. When do this I encountered a screen with redirect issues. This is why I asked if I should have used the http://freehuckleberryads.com .

    Thanks
    Doug

  • Jack Kitterhing
    • Code Norris

    Hi there Doug,

    Thanks for the additional information.

    Change your .htaccess to

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ wp/$1 [L]
    RewriteRule . index.php [L]

    And in the defines in your wp-config.php add http:// to the domain :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Huckleberry Press
    • WPMU DEV Initiate

    Hi Jack,

    I copied the current line from my wp_config.php the way it displays currently:

    define('DOMAIN_CURRENT_SITE', 'www.freehuckleberryads.com');

    if I understood you correctly I would add http:// in front of the www.

    I tried putting the http:// in front of the www. and it does not work

    I have also tried taking the www. out and put http://freehuckleberryads.com and it doesn't work.

    I tried the above after copying the .htaccess code and replacing it with the new code you sent.

    Thanks
    Doug

  • Ash
    • WordPress Hacker

    Hi @Huckleberry Press

    As I closed your latest thread for duplication, just chiming in here.

    Did you try Jack's htaccess?
    Would you please post your wp-config.php code in http://pastebin.com and send me the link? (remove all your db info from the code)
    Do you use domain mapping plugin?
    If you disable that classified plugin, does the issue exist?

    Please let me know.

    Cheers
    Ash

  • Huckleberry Press
    • WPMU DEV Initiate

    Hi Ash~

    I did try Jack's htaccess.

    I do not use the domain mapping plugin.

    I disabled the classified plugin and the issue still does exist.

    The wp_config.php is the pastebin.com. Never used this option before so don't know if I did it correctly. I will attach the file just in case it did not work.

    Thank you.
    Doug

  • Huckleberry Press
    • WPMU DEV Initiate

    Hi Ash~

    Don't know if the paste bin worked. I see for some reason the attachment keeps getting in extension error message. I will just paste in the code here.

    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'xxxxxxxxxx');

    /** MySQL database username */
    define('DB_USER', 'xxxxxxxxxx');

    /** MySQL database password */
    define('DB_PASSWORD', 'xxxxxxx');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define('AUTH_KEY', 'EG+HRjp ~8X4-yFdV,wZm^j:=+7a]Y6/uPB=/+9Zo5CD-1iVK1jWg[;s?%=g{,');
    define('SECURE_AUTH_KEY', '8tkw3[BEhp9#3[3[ b|(yt6_Sj!(W9l(lMO)GC+!-dZ*]&v)3578U$PFyvG/w1');
    define('LOGGED_IN_KEY', 'b?q+T0V6{5lCE{!)^gOWSNyL!5U%;zvWPX6yA^Gpo|J4qQBA,BS[;fN+3?WG[)');
    define('NONCE_KEY', 'mg<e7cDQ0t)lc3,x+cvax%@+x.JqNT~sRCle[mQb}ws3@njFoFd7|d1fpGvLt+/[');
    define('AUTH_SALT', '_+NKc+1VLK7Mru+-{x[6wo_E3c(k@LRx$Z4k8%`&c$q/nmX/N&EI RoQe+5DiR');
    define('SECURE_AUTH_SALT', '[>0TSp<Zk7<D_4Bdv^ZNN26zBA:3jY_zK/o0EP9TH=7);AD*V{|>]|br/.@IEO');
    define('LOGGED_IN_SALT', '*I&q`Jw65]&/tP@PlB,3_h~A)kRAD.|6}-vY8[B7Xx)M@s~~ r3}kTA>w(6/*&E9');
    define('NONCE_SALT', '~S~+~(|b:cOGMIid{n()|fgEkff?/$q[]0MgcDxj|:smiley:%>c-K kF|hHBZ^`;g9jUH');

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'xwq_';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
    * language support.
    */
    define('WPLANG', '');

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'www.freehuckleberryads.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Thank you.
    Doug

    • Ash
      • WordPress Hacker

      Did you create wildcard subdomain in your server? If yes, send me login and ftp details.

      To send me details, please use our contact form: https://premium.wpmudev.org/contact/

      Select: I have a different question
      Subject: Attn-Ash
      Details: Send all required details (admin info and/or ftp details) with a link of this thread, so that I can track.
      Also post a note here once you send the info.

      I will be happy to take a look :slight_smile:

      Cheers
      Ash

    • Ash
      • WordPress Hacker

      Though you didn't send your site login information. I have checked your cpanel but I don't see any subdomain option in the panel.

      The package you bought from bluehost, is there subdomain available for your package?

      Please let me know.

      Cheers
      Ash

  • Huckleberry Press
    • WPMU DEV Initiate

    Hi Ash~

    Sorry for the miscommunication. I set you our site login information.

    To manage and create subdomains, login to Bluehost, click on Cpanel. Wait until automatically logs you in, from the Cpanel Dashboard, scroll down to domain manager and click on the subdomains icon. You can see the only subdomain we have created is the wildcard.
    ( *.freehuckleberryads.com).

    Thank you.
    Doug

  • Huckleberry Press
    • WPMU DEV Initiate

    Hi Ash~

    I wient to the website and didn't really see that it was working. Still see the same results. Not able to navigate using the tabs except for the Directory tab, it works as it is pointed to a different location.

    The Network login info is the same as the Bluehost login. Same user and PW.

    Thank you
    Doug

  • Huckleberry Press
    • WPMU DEV Initiate

    Hello Ash~

    Thank you very much. You are awesome!! If you don't mind sharing, where did I go wrong in my setup? I learning this Wordpress as I go along.

    I only have one more question, when initially going to the page now it asks for a login. This might be confusing for the person viewing the website.

    What would be the best way to make this login that is showing not be there?

    Thank you
    Doug

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.