Endless Loop and Redirect to Signup Page

I have followed the instructions for the multi-db install, verified with provider (hostgator) that permissions are correct worked through a few kinks on adding user to the database.

Now after this every attempt to go to the move-blogs.php like redirects in an endless loop, as does the main site address and any variation e.g. www.

I have edited, removed, modified the .htaccess in testing it is below for reference:

RewriteEngine off
<IfModule mod_suphp.c>
suPHP_ConfigPath /home/meshout/public_html/envexa.com/php.ini
<Files php.ini>
order allow,deny
deny from all
</Files>
</IfModule>
# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]
# END WordPress

Snippits from my move-blogs:

///DB Settings
$dbname = "*****_wdps3"; //This is your current database
$blog_table_prefix = 'wp_'; //Prefix of your wpmu blog tables, most likely this won't need to be changed
$newdb_prefix = '*****_wdps3_'; //This is the prefix of the db's you're moving your tables into - we assume they are all the same, if not, you're in trouble

//We need info to connect to the databases
$dbhost = 'localhost';
$dbuname = '*****_wdps3';
$dbpass = '*****';

//How many db's are you moving into (16, 256, or 4096)?
$db_scaling = '256';

Snippits from my db-config.php:

define ('DB_SCALING', '256');
//------------------------------------------------------------------------//
//---DC IPs---------------------------------------------------------------//
//------------------------------------------------------------------------//
// Usage: add_dc_ip(IP, DC)
// EX: add_dc_ip('123.123.123.', 'dc1');
add_dc_ip('174.120.40.*', 'dc1');
//------------------------------------------------------------------------//

add_db_server('global', 'dc1', 1, 1,'localhost','', '*****_wdps3_global', '*****_wdps3', '*****');
add_db_server('00', 'dc1', 1, 1,'localhost','', '*****_wdps3_00', '*****_wdps3', '*****');
add_db_server('01', 'dc1', 1, 1,'localhost','', '*****_wdps3_01', '*****_wdps3', '*****');

Now the domain by default on hostgator has CNAMES setup for it on www and so on, and I am not sure that has anything to do with it. There are 100 of post on this topic on wp.org and other sites but most all seem to point back to other plugins being installed. This is a fresh install with all plugins disabled, the two by default w3 and askimat I believe.

Any help would be greatley appreciated, spent most of the day trying to troubleshoot this and well its driving me crazy :wink:

  • Mason

    Hiya mbm,

    First off, welcome to WPMU DEV!

    Can we get a bit more information about your setup? What version of WordPress Multisite are you running? Anything showing up in your php error logs?

    I'll ask a couple devs to come by and take a look. I haven't read of anyone having an infinite loop issue on move-blogs.php and I'm able to see your front page and sign-in pages without any trouble.

    Still, we'll take a look with ay.

    Thanks!

  • mbm

    Sorry for the delay in updating this, it seems that I got passed this part to an extent it was related to some sort of endless loop between a CNAME is my only guess I can see and partially from problems in moving the databases.

    I seriously hate a resolution to a problem that is not clear, but, well, It seems to be working outside of a few mysql_fetch errors that I will work through and reach back out to you if I need any help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.