eNewsletter blank screen on create newsletter

I have a problem with e-newsletter on one of the sites in my multisite. On all others it is fine but on the Bristol sub site it hangs with a blank screen on newsletter create. You can only see this problem if you are an admin so I have provided maniu with admin access to this site.

http://reformgroups.net/bristol/wp-admin/customize.php?wp_customize=on&theme=iletter&newsletter_id=15&return=admin.php%3Fpage%3Dnewsletters

  • Chris Carrigan

    OK - here is the error text
    Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead. in /home5/reformgr/public_html/wp-includes/functions.php on line 2876

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home5/reformgr/public_html/wp-includes/functions.php on line 3012

    Notice: bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in /home5/reformgr/public_html/wp-includes/functions.php on line 3012

    Notice: bp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 1.7.) in /home5/reformgr/public_html/wp-includes/functions.php on line 3012

    Warning: Cannot modify header information - headers already sent by (output started at /home5/reformgr/public_html/wp-includes/functions.php:2876) in /home5/reformgr/public_html/wp-includes/pluggable.php on line 875

  • aristath

    ok. All these are pure informational, the "notices" are there because we have to be compatible with previous versions of wordpress as well.
    This however could be the cause of your issue:

    Cannot modify header information - headers already sent by...............

    Could you please try de-activating ALL other plugins on this site and test again?
    The issue should not exist there once you do...
    You can then start re-activating the plugins one by one and test again to see which one is causing this.
    This is a really common issue... here's what's causing it and how to fix it: https://premium.wpmudev.org/forums/topic/wordpress-error-1#post-399933

    Please let me know if that works for you...

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.