eNewsletter: Bounce test message not found!

I'm trying to test my eNewsletter configuration. For background, I'm using a 3rd party SMTP relay.

I keep getting the following error message when I test the Bounce Settings:

Bounce test message not found!

But when I manually check the POP "bounce" account, the test bounce messages are there and the "to" and "from" addresses match the settings in eNewsletter.

Any ideas?

  • Temporal Sales

    You get the error message, but the emails/test bounce messages are there correct?

    OK, now the "test bounce" function is working without any error messages. But as far as I can tell, the bounce e-mails are correct, each with a different number.

    What happens when you try the send preview on create a newsletter?

    Test messages to e-mail accounts outside my server are failing while test e-mails sent to address on my server are going through.

    The failure message is "Error sending email. Please check outgoing email settings."

    I also tried sending a sample newsletter to a test list. It too failed to go out with the same error.

    Maybe this is an issue with the Ports setting? (See my post #447416)

    I'm sending on Port 25 because my relay service's recommended port of 2525 wouldn't work.

    I'm still awaiting a reply from my hosting service to my inquiry concerning port access.

    Thanks!

  • Temporal Sales

    Update #1:

    I have resolved the Port issue, turned out to be a conflict with my server's firewall, which has now been corrected and I can send on my relay service's suggested port of 2525.

    To note, I also installed the latest eNewsletter update this morning.

    Unfortunately, I still can't get the blog test to work consistently. Now it's back to telling me it can't find any bounced e-mails.

    You get the error message, but the emails/test bounce messages are there correct?

    Below is the latest test bounce e-mail that eNewsletter couldn't find. It appears correct to me. Perhaps someone else can detect something.

    Date: Tue, 18 Jun 2013 16:05:40 +0000 +0000 [12:05:40 PM EDT]
    From: news@craftshoppers.com <news@craftshoppers.com>
    To: bounce@craftshoppers.com
    Subject: Test-Connection-Bounce-1371571540

    Any ideas?

  • Jack Kitterhing

    Hi there @Temporal Sales

    Thank you for the updated information on this thread much appreciated, Do bounced emails actually end up in your bounce email box? From your post, I'm presuming they don't, but I wanted to check as sometimes there can be a glitch with the error message.

    Can you test the bounce by sending to a dummy address as that should be bouncing correctly.

    This will help us narrow down the issue :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • Temporal Sales

    Can you test the bounce by sending to a dummy address as that should be bouncing correctly.

    OK, now we're making progress. I created a bad e-mail address on an external server of mine and it appears the bounce function itself is working. See dashboard excerpt appended below.

    However, I'm still getting the "Test message not found" error message when I try the bounce test. So it looks like it's an issue with the test routine rather than the bounce function itself.

    Do bounced emails actually end up in your bounce email box? From your post, I'm presuming they don't...

    Yes they do, both following all the self-tests and my most recent test sent to a bad e-mail address. See below.

    Let me know if there's anything else you'd like me to try, but at least it looks like we're up and running.

    Thanks!

    From the Bounce POP

    Date: Tue, 18 Jun 2013 18:05:17 +0100 [01:05:17 PM EDT]
    From: Mail Delivery Subsystem <MAILER-DAEMON@punt9.authsmtp.com>
    To: bounce@craftshoppers.com
    Subject: Returned mail: see transcript for details

    ERROR: Your message could not be delivered.
    The mail server generated the following error message:
    The original message was received at Tue, 18 Jun 2013 18:05:05 +0100 (BST)
    from mail-c232.authsmtp.com [62.13.128.232]

    ----- The following addresses had permanent fatal errors -----
    <badaddress@temporalsales.com>
    (reason: 550 #5.1.0 Address rejected.)

    ----- Transcript of session follows -----
    ... while talking to smtp.secureserver.net.:
    RCPT To:<badaddress@temporalsales.com>
    <<< 550 #5.1.0 Address rejected. 550 5.1.1 <badaddress@temporalsales.com>... User unknown
    DATA
    <<< 503 #5.5.1 RCPT first

    ____________________

    From the eNewsletter Dashboard:
    Date of Last Sent Email Subject Sent From Sent To Bounced Opened Actions
    June 18, 2013 05:04:55 Test Newsletter #4 (with bad addresses) <news@craftshoppers.com> news@craftshoppers.com 4 members 1 members 5 members

  • Maniu

    Hey @Temporal Sales

    So, generally it should not happen - if it connects to correct inbox(in your case bounce@craftshoppers.com) and cant find the message, it can indicate few things:

    1. message is not received before plugin is looking for it - could you see how long do you have to wait for message to appear in inbox(click test bounce button and switch to email client and constantly refresh:grinning:
    2. Message is getting in spam or some other weird folder - i assume its not the case.
    3. Other magic thing... some kind of server incompatibility or veeery well hidden bug

    Would it be possible to send test newsletter to 2 emails and one of them will be fake? This way you will see if if it actually works - chance is high:slight_smile:

    Let us know how it goes!
    Maniu

  • Temporal Sales

    Would it be possible to send test newsletter to 2 emails and one of them will be fake? This way you will see if if it actually works - chance is high:slight_smile:

    Yes, that's what I did to confirm the plugin itself is working, including the bounce notifications.

    2. Message is getting in spam or some other weird folder - i assume its not the case.

    Correct, no notifications in the "spam" box. All of them are in the "inbox."

    1. message is not received before plugin is looking for it - could you see how long do you have to wait for message to appear in inbox(click test bounce button and switch to email client and constantly refresh:grinning:

    I'll try to time it, but on first impression I'd say this is the problem with the test routine. The error message appears pretty fast after you click "test", I'd say about 10 seconds later. That may be too quick given the time it takes for bounce messages to work their way through the world's mail servers.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.