eNewsletter exclude one group

Subscribe to Newsletters is at https://christiangays.com/subscribe-christian-gays-newsletters/

My Groups are

1 Newsletters
3. Test Admin
5. Women

My shortcode is [enewsletter_subscribe show_name="1" show_groups="1" subscribe_to_groups=“1,5”]

i.e. I want subscribers to have the option of Newsletters plus Women, but I don’t want Test Admin to show up anywhere.

For non-logged in user it shows correctly with options to choose Newsletters and Women

However, for logged in users it doesn’t show any options. It just has one button saying “Subscribe to Newsletters”. There is no option for the “Women” group.

and if I am logged in and already subscribed, it shows the ones I am subscribed to, but the Unsubscribe Link unsubscribes all, with no options. It’s all or nothing.

I would like to change it so that Logged in members get to choose Newsletters and Women, the same as non-logged in users.

Then I would like to remove the Unsubscribe Link and instead change

Subscribe to: to read Subscribe or Unsubscribe to:

Can you please help me with this. Support Access is granted.

Thank you!

  • Predrag Dubajic

    Hi Mary,

    Subscription form shows differently for logged in users and from visitors because logged in users gets to save his choice to his account and later on edit it, so when you click on Subscribe button while logged in it will show the available groups so user can choose what to subscribe to.

    Visitors on the other hand can't change this later on and that's why the options are shown straight on subscription.

    About the shortcode you're using, subscribe_to_groups attribute, when used, will automatically subscribe the user to the groups you add there, so if you add 1 and 5 then the visitors will be automatically subscribed to those groups and they will not show as available options to them.

    However, for logged in users it doesn’t show any options. It just has one button saying “Subscribe to Newsletters”. There is no option for the “Women” group.

    I've created new account and tested this but the groups are showing properly for me as you can see here:

    Can you elaborate this a bit more please?

    and if I am logged in and already subscribed, it shows the ones I am subscribed to, but the Unsubscribe Link unsubscribes all, with no options. It’s all or nothing.

    This is because there's no need to unsubscribe to change subscription groups, you simply select the ones you want from the above page and save your settings.

    Then I would like to remove the Unsubscribe Link and instead change
    Subscribe to: to read Subscribe or Unsubscribe to:

    I'm afraid that this is not possible and it would require rewriting the plugin functionality completely in order to have it work this way.

    Best regards,
    Predrag

  • Mary

    OK perhaps I did not explain well enough. Let's just take one thing at a time.

    What you are showing in the image is the ability to subscribe to
    Newsletters
    Test Admin
    Women
    but as I said in the original ticket, I want to only show options for Newsletters and Women. Nobody should be able to register for Test Admin!

    I have now added the following Custom CSS

    .subscribe_groups li {
    display: none; }
    .subscribe_groups li:first-of-type {
    display: block; }
    .subscribe_groups li:nth-of-type(5n) {
    display: block; }

    but now it just shows Newsletters, not Women, so obviously I don't have the css right for #5 (Women).

    If I am logged in, but not subscribed to Women, I need Women to show up as an option.

    Can you please tell me how to do just make Newsletters and Women be an option for logged out and logged in users.

    Thank you.

  • Mary

    Thank you Predrag. Now we are making some progress. I can now see for logged out users subscribe to Newsletters and Women. This is perfect.

    Now I would like to address the logged in users.

    If I log in and am not subscribed to anything there is just a button that says Subscribe to Newsletters.

    I want my women to also have the option to subscribe to Women.

    Can you tell me please how to do that.
    Thank you.

  • Mary

    OK I logged in as test2. When I go to My Stuff -> Newsletters Subscribe / Unsubscribe this is what I see.

    That screenshot is in Chrome so I logged in as test1 in Safari to see if it was different, but it isn't.
    I would like to see what you are showing - i.e. the options to choose Newsletters and Women, but I don't.

    Therefore I clicked on the only button available, thinking that I could unsubscribe and see if it would bring up the options, but it didn't, so I logged out and went to My Stuff -> Newsletters Subscribe / Unsubscribe again but all I get is the same image as above with button to Subscribe to Newsletters.

  • Predrag Dubajic

    Hi Mary,

    Hmm, I'm kinda lost here, I tried this with your test2 user and I still see the options properly like this:

    I then asked few of my colleagues to check this as well and they are all seeing same thing on their end.

    Can you try clearing your browser cache, check in incognito mode or try on different PC and see how it looks there?

    P.S. I had to change password for test2 user in order to get in so you will need to revert it back or create new one for it.

    Best regards,
    Predrag

  • Mary

    It just doesn't work correctly all the time. I have deleted cache and gone incognito, but here is another example of a problem.

    I subscribed as a non-member to "Women" (not Newsletters) from this link https://christiangays.com/subscribe-christian-gays-newsletters/ See screenshot.
    but when I go to check I am subscribed to both Women and Newsletters.
    See screenshot.

    Situation #2

    I log in as "test". I'm seeing that I am subscribed to both Newsletters and Women. Both are ticked and now I want to Unsubscribe from both, so I leave them ticked and click the Unsubscribe link. The result is that I am now in 3 groups - Unsubscribed, Newsletter and Women. How is that supposed to work?
    See screenshot.

  • Adam Czajczyk

    Hello Mary,

    I hope you have a nice day today!

    After reading this thread and doing some tests on my end I think that you could try a slightly different configuration:

    1. Since you are hidding "unwanted groups" from subscription forms with CSS already, the subscribe_to_groups=“1,5” attribute could, or rather should, be removed from the shortcode. The way it works is - to quote my colleague Predrag - it "will automatically subscribe the user to the groups you add there"; therefore that might be interfering here

    2. Please go to the "eNewsletter -> Settings - > General Settings" page and near the bottom of it look for "Default Groups" option; make sure that none of the groups is checked/ticked there so there'd be no "default" subscriptions.

    Once that's set up, please clear the caches and check it again as a visitor (not logged in user) first and then as logged in user (but in this case try using a freshly registered/new test account).

    Let's see if that helps. If not, please revert changes and we'll keep working on this.

    Best regards,
    Adam

  • Mary

    Hi Adam,
    I was really optimistic that the changes would solve all the problems, but they didn't. I did as you suggested (both made sense to me). Then I cleared cache and went incognito.

    The first test I tried - I registered as a non-member (test4) for just Newsletters. See screenshot but when I checked the registration I was registered for both Newsletters and Women, AND I didn't receive the Welcome email that I is normally sent to all new subscriptions. See screenshot

    I didn't test any further. I figure if this doesn't work, there isn't any point in trying other tests.

    Next suggestion?

  • Predrag Dubajic

    Hi Mary,

    As you can see in the e-Newsletter settings page the confirmation email is only sent to non-registered members so that's why you're not seeing any emails when testing with test4 user.

    About the subscribed groups, I've checked your settings and see that "Newsletters" group is selected as default group and that's why you're being subscribed to that as well.
    While I was checking this I was unable to disable this group as default group as the settings didn't update properly when I saved the settings when none of the groups are selected.
    After that I tested this on my installation as well and I was able to replicate this issue so I have created bug report for our developers about this.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.