eNewsletter is stripping out HTML links

I wanted to include a link to a YouTube video - so I put in a link to the clip - but the plugin send the email without the link.

It doesn't just strip the link and keep the "Click Here" text - the whole thing is gone.

Can you fix this?
Thanks!

  • Alexander

    Hi @Marlen,

    I've just tested this, and I'm not getting the same results. Can you see the link in the customizer preview? Or do they just not show up when the email arrives?

    Also, could you try testing for a plugin conflict? There might be some kind of filtering going on that is happening outside of e-Newsletter. To do this, deactivate all your other plugins, then check the customizer, or send a preview email to yourself. (depending on what point you've determined the issue to occur)

    If it works with the plugins turned off, try turning them back on a few at a time until it stops working again. With this, we can narrow down a conflict to a specific plugin. It can also be a theme issue if your theme has any filtering options available. You might want to try out switching to the TwentyThirteen theme in your testing as well.

    Let me know what you find out!

    Best regards,

  • Marlen

    Hey Alexander -

    Thanks for your quick reply. I tried again and now it's working if I put in the link, then save the newsletter, close and then reopen.

    So that's a relief.

    But then this afternoon when I tried to tweak the email template, now the "Not interested anymore? Unsubscribe instantly" isn't working.

    Can I give you admin someone at WPMU admin access to fix this? I tied using the other template emails and they aren't working either.

    Thanks!

  • Alexander

    Hi @Marlen,

    Good to hear this is working now! Thanks for letting me know!

    Even with the second issue, it does sound like a possible plugin or theme conflict. If you have any more issues like this, I'd advise testing for a conflict as described above/

    Another thing you could do is check the javascript console for errors. In Chrome go to "View -> Developer -> Javascript Console" and in Firefox you can go to "Tools -> Web Developer -> Console" Try this when the "customizer" view is open, and if you have any errors just let me know.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.