enewsletter send test email – fail error

Hi,

I have tried to configure the enewsletter to use my smtp to send emails but I get a an fail error message.

I have installed knews (another newsletter plugin) and was able to send a test email with no issue with the same configuration data.

any thoughts what might cause this to brake with enewsletter?

Please advise,

thanks,

David

  • Vinod Dalvi
    • WP Unicorn

    Hi David,

    I hope you are well today and thanks for posting on the forum.

    I have tested it on my test site using latest version of e-Newsletter plugin and found it's working fine as shown in the attached screenshot.

    Is it working fine for your if you use SMTP Server like smtp.gmail.com ?

    Would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,

    Vinod Dalvi

  • David
    • Site Builder, Child of Zeus

    Hi Ash,

    my reply might be long however it will provide you more insight on this issue.

    This is strange when I use knews with port 587 the email is sent with no issues. see the enclosed image.

    please note that if I select the 'Conn mode:' = IsSMTP() [instead of IsSendmail()] in the knews settings I get this error:

    "SMTP -> ERROR: Failed to connect to server: Connection timed out (110)SMTP connect() failed. " which I think is the same for enewsletter.

    its hard for me to believe that the port is closed as the hosting service I use is the same one for the websites and for my emails. Their instructions is to use port 587 to configure mail clients so why they will close it on the website hosting knowing that someone will need to use SMTP to send emails from their website.

    just to play it on the safe side I called my hosting services and asked the question.

    the answer is – YES, the port is open.

    so why I get the port closed message when I try to access it?, you must ask.

    I believe that you tried to access the server from the outside i.e. ping the server through port 587 which is closed to inbound traffic hence your screenshot is correct. this make sense as a port can be closed for inbound traffic but open to outbound traffic as I confirmed with my hosting provider.

    in my humble opinion this might have to do with the 'Conn mode' . I'm not sure if enewsletter have this option in the setting and the default is IsSMTP() hard coded in the back end.

    please advise,

    Thanks,

    David

  • Ash
    • WordPress Hacker

    Hello @david

    I hope you are well today.

    Thank you for your nice explanation :slight_smile:

    I have used a online tool that detects if the port is open, but I think you are right here. As the same settings working fine in k-news plugin, I will pass the message to the developer.

    I can see you are currently using k-news plugin. Do you like to use our e-newsletter plugin? If yes, then I can assign a SLS developer in this thread who can check the issue taking a closer look.

    Please let me know.

    Cheers

    Ash

  • David
    • Site Builder, Child of Zeus

    Hi Ash,

    I use knews in my other sites and when I got the membership with WPMUDEV I thought I will give the enewsletter a try. it didn’t work.

    yes, I would like to resolve this enewsletter issue and you can disable the knews and assign a SLS developer to work on this.

    thanks,

    David

  • Ash
    • WordPress Hacker

    Hello @david

    yes, I would like to resolve this enewsletter issue and you can disable the knews and assign a SLS developer to work on this.

    Thank you.

    Would you please send me your admin login and FTP login so that I can pass to the developer?

    To send me details, please use our contact form: https://premium.wpmudev.org/contact/

    Select: I have a different question

    Subject: Attn-Ash (this ensures that it will be assigned to me)

    Details:

    1. Send all requested details

    2. Send a link of this thread so that I can track

    3. Send any other relevant link

    I will be happy to take a look :slight_smile:

    Cheers

    Ash

  • Hoang Ngo
    • Code Slayer

    Hi, @david,

    After different tests, I can sure that your host blocked the port 587 for out going request. I’ve tested with various plugins

    -Knews newsletter

    -E-newsletter

    -WP SMTP mail

    All of them gave me the same information.

    The conn mode IsSendMail actually using the Server Sendmail app to send, which mean that email will be sent by the server, not through SMTP. That’s why it works when you’re using that mode.

    In this case, I think you will need to check with your host provider for open that port :slight_frown:. Furthermore, I placed a file for test if the port open, you can check that by going to http://yourdemosite/info.php

    Best regards,

    Hoang.

  • David
    • Site Builder, Child of Zeus

    Hi Hoang,

    I just had a conversation with my hosting and was able to use port 25 for the Outgoing SMTP Email Settings to solve the issue. I guess the information provided was not clear.

    Now I'm facing the same issue with Bounce Settings where it fails to send the test message.

    The alternatives I tried with my hosting rep on the phones are:

    pop.1and1.com port 110 or 995 both with SSL

    imap.1nad1.com port 143 0r 993 both with SSL

    all combinations above fail to send the test email

    Please advise,

    Thanks,

    David

  • Hoang Ngo
    • Code Slayer

    Hi @david,

    I hope you are well today.

    I’ve just take a check, it seem your port 995 blocked too :slight_frown:

    Can you please try using the port 25, without SSL encryption? I think it can work. In addition, I recommend to check with your host to open the port 995 & 587, as port 25 is the non-encrypted port, which can cause potential security issue.

    Best regards,

    Hoang

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.