eNewsletter uninstalled after upgrade

After upgrading to WP 4.0 all the enewsletter installations on my multisite get uninstalled and i lost all my contacts, groups, newsletters and statistics.

This is the second time this happens to me. Luckily i have my contacts stored, but i would like to retrieve all the configurations back and not to have to set again every websites configuration.

What can i do?
Thanks

  • marko

    This morning, after upgrading the wordpress i started deleting some sites on my multisite instalation and then something odd happened. A window opened saying i hadn't the permissions to delete those sites, which wasn't true because i was logged as superadmin.

    Anyway y decided not to delete 3 by 3, and started deleting them 1 by 1.

    I say this because after that i noticed the disappearing of the enewsletter configuration and exactly the same has happened egain 5 minutes ago! I deleted 3 websites from the multisite and when i returned to the dashboard the enewsletter was uninstalled!

    I don't have a clue why such a strange thing can happen?

  • Michelle Shull

    Hi, Marko!

    That's definitely odd! Double odd, because 1. e-Newsletter shouldn't uninstall itself, and 2. even if it did, it shouldn't delete all your data, which is stored in the database.

    Let's run through some troubleshooting questions real quick.

    1. Are you using any caching or security plugins?
    2. Who is your host? Can you access your server error and/or access logs?
    3. Have you made any changes, big or small, to your site that might correspond to when this issue started?
    4. Are you seeing any other odd behavior on your site?

    Thanks, marko!

  • marko

    Hi Michelle,

    I would like to know where exactly should i look in the database to retrieve my updated mailing list which i have stored on some website of my multisite.

    I'm on hostgator's shared server.

    I'm not using caching or security plugins.

    The only thing i recall, which is odd happened when as a superadmin i trieda to delete 5 websites ontesting i was using before and the screen whent grey and said to me i have not permission to do that.

    After that i recall entering my main website and seeing the newsletter configuration undone and uninstalled.

    Same thing happened one time before after updating to a more recently version of the plugin.

    The rest of the website operations are working correctly and none bad behavior is being noticed neither by me or any other memeber of my group.

    Is there any way to restore old configurations? where should i look in the database to retrieve my information?

  • Tyler Postle

    Hey Marko,

    Hope you're doing well today!

    Glad one of the issues is resolved so far :slight_smile:

    As for eNewsletter uninstalling itself and deleting data, I haven't been able to replicate that - I just updated it to the latest version and deleted a few subsites and it never uninstalled.

    However, you can check your database tables starting with wp_enewsletter for the data if it is there. There is a few different tables that should start with that.

    Another option is downloading a copy of your database then searching it for something that you know should be in it. ie. an email that is gone.

    Look forward to hearing back on this Marko!

    All the best,
    Tyler

  • marko

    Thanks Tyler,

    I searched in the database for the data and unfortunately i found nothing.

    The tables with old newsletters, statistics and member emails are gone.

    Only the new ones i generated after reinstalling the plugin are there.

    I still don't understand why it uninstalled unexpectedly everything after upgrade and after deleting those pages on the multisite.

    I'll give it one last try and if it makes again the same thing i'll choose another option and i'll discourage people from installing this plugin on their sites.

    Bye

  • aristath

    Hello again @Marko, I hope you're well today!

    I talked about this issue with 2 other staff members and we each tried to replicate it on our own sites following the steps you described.
    I personally tried it on a shared host, a VPS on DigitalOcean, a test site on WPEngine and finally a test site on my localhost using Vagrant.
    No matter what we tried we could not replicate this issue, and nobody else has reported anything remotely similar...
    This seems to be isolated to your installation and we can't figure out why that happened.
    The only thing that I can think of at this point is a corrupt database or some other weird server issue. The plugin does not simply delete its tables and there have been no major changes to the way it handles its db tables that would justify this.
    Have you contacted your host and ask them if they know what could have caused this? Perhaps they have a backup of your database before the update?

    Please advise,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.