Enroll button is not working when the SSL plugin is enabled on the site

When a user tries to create a new account clicking on the “Create an account” at the https://l***n.v***s.com/student-login/ page and it is redirected to https://l***n.v***s.com/courses-signup/ page, the signup form does not work if the any SSL plugin, like Really Simple SSL, is enabled on the site. After filling the form nothing happens.

  • Predrag Dubajic
    • Support

    Hi System,

    Hope you’re doing well.

    I had a test with this on my installation and after activating Really Simple SSL I was able to replicate the issue at first but when I flushed my permalinks it started working fine.

    This however didn’t work on your installation so it looks like there’s something else still causing it there.

    I do see that you have two SSL plugins so can you try disabling “SSL Insecure Content Fixer” and leave only “Really Simple SSL” active.

    Also, I see that you have used W3TC plugin and there seem to be some leftovers of the plugin so can you delete those so there’s no caching affecting your site, you can find a guide for that here:

    https://www.wpmyweb.com/how-to/completely-uninstall-w3-total-cache-plugin-updated.html

    After that go to Settings > Permalinks in your admin panel and save the settings two times there in order to flush the permalinks.

    Just to be sure that there’s no caching anymore affecting the site check if you have any server side caching and clear that after you have flushed permalinks.

    Check the registration process and let us know if it works now.

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.