Error 404 on new pages

Hi there,
I'm really hopping you'd help me on this one. Out of a sudden I can't view or preview any newly created page. here is what I've tried so far:
1- Premalink, save changes
2- manually resetting .htaccess file using ftp
3- Tried default wordpress theme, same thing
4- deactivated all plugins

I'm going crazy on this one.
Please assist

  • Patrick Freitas
    • Staff

    Hi Nizar

    Sorry to hear that you are having this problem, I checked the wp-admin and the configurations appear to be fine, I would suggest you clear only the cache setting and disable the cache plugin for a moment.
    We can try this solution:

    -Login to your server using FTP, and modify the .htaccess file which is located in the same location where folders like /wp-content/ and /wp-includes/ are located. The easiest thing you can do is to temporarily make the file writeable by changing the permissions to 666.

    Try again, Go to Settings » Permalinks, and simply click on Save Changes button.

    And try to create a new page.

    Don’t forget to change the .htaccess permissions back to 660 and enable the cache plugin,

    Let me know the results.
    Have a great day.
    Patrick Freitas

  • Nizar
    • New Recruit

    Dear Patrick,

    Thanks for your reply, and I'm sorry to tell you that what you suggested didn't work either. I followed the exact steps you mentioned except setting the permission back to 660, that should be 644 (Public should be able to read).
    Any other suggestions?

    Thanks,
    Nizar

  • Patrick Freitas
    • Staff

    Hi Nizar

    Sorry to hear that.

    Is your website hosting in a shared service or dedicate server?

    I can see that you are using Nginx, I would suggest to restart the Nginx service or switch to Apache and check if the problem has gone. Then back to Nginx.

    Once the Nginx struct is different from Apache, once the Apache is who reads .hataccess file.

    If you are not sure how to do it, or this is a shared hosting service wouldn't you mind please ask the hosting support to run those test.

    Please, always is better idea to run the test on a staging site, if you can't do it wouldn't you mind to provide a full backup.

    Let me know the results
    Have a great day,
    Patrick Freitas

  • Nizar
    • New Recruit

    Hi Patrick,

    It turned out to be a WPML issue, I opened a case with them, but still didn't resolve it.
    Everything works fine when WPML is disabled.
    If you have experienced anything like this before, please do share it with me.

    Thanks again for all previous suggestions.

    Regars,
    Nizar

  • Patrick Freitas
    • Staff

    Hi Nizar

    Sorry I never had this problem before, but I made a search on the internet there is a link that you may you want to check : https://wpml.org/forums/topic/suddenly-all-our-webpages-return-a-404-page-not-found/

    However, Is a strange behave of the site, was there any update just before this start to happen?
    Let me know when then fix it and share the solution it can help figure out other further problems.

    Have a great day,
    Best Regards
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.