ERROR 500 – website down after installing many plugins at one

Hello, I’ve been checking all the plugins these 2 last days and I’ve installed 25 of them…I wanted to test everything… And I noticed on many of them an error! So I refreshed and tried to reinstall them and they were still making an error…

I refreshed and now my website is down…

– White page on firefox

– Error 500 with chrome

The FTP is working, and shows everything is fine on the server…

Could you tell me

– If there is a diagnostic tool to know wich plugin not to install?

– As we can install plugins from mpmu login panel, could we uninstall them from there too???

– How can I remove the plugins from the ftp?

Thank you

  • tom
    • WPMU DEV Initiate

    Ok the 3 plugins added from all the plugins that didn’t want to install seems to be



    – Q&A

    I found them from the FTP (wp-content>plugins>classified by date), deleted them and it’s working back after deleting my cache (on chrome click F12 > Options (show by … on the right) > uncheck cache, F5, recheck cache).

    will try to reactivate them one by one. :slight_smile:

    I let the post if anyone encounter the same problem!

  • Adam Czajczyk
    • Support Gorilla

    Hello Tom,

    I hope you’re well today and thank you for your question!

    This unfortunately happens some times when you install too many plugins and/or try to activate them “at once”. There’s no way to predict this though as it heavily depends on your server’s configuration (among other factors).

    The way to go here would be to:

    1) access your WordPress install via FTP

    2) go to “/wp-content/” folder

    3) rename the “plugins” folder to something else (I personally prefer name like “pluginsOFF”

    4) create new and empty “plugins” folder there

    At this moment, it would be best to try to access admin dashboard. If this happened indeed because of the plugins, you should be able to login and see that all the plugins were disabled. If this works then proceed as follows:

    5) copy all plugins (folders and its contents) from “/wp-content/pluginsOFF/” folder to “/wp-content/plugins/” folder (those plugins will remain disabled)

    6) get back to your admin dashboard and enable plugins one-by-one

    This way you should a) regain access to your site b) be able to identify the plugin(s) causing the issue. Other than that, there are some tools that could be helpful in troubleshooting WordPress issues but in this case this is most basic and I’d say the only way to proceed.

    Keep me updated please!

    Best regards,


  • tom
    • WPMU DEV Initiate

    Ok I tested them one by one and The BROKEN PLUGIN were:

    MarketPress eCommerce

    Comments +

    Support System

    leading to a server error 500 everytime I activate them.

    Do you know what I can do? Especially for MarketPress eCommerce and Comments +, I really need them.

  • Rupok
    • Support Ninja

    Hi tom

    I hope you had a wonderful day.

    Due to the generic nature of 500 internal server error, it does not tell the developer anything. Asking how to fix an internal server error is like asking your doctor how to fix the pain without telling them where the pain is. Having that said, internal server error in WordPress is often caused by plugin and/or theme functions. Other possible causes of internal server error in WordPress that we know of are: corrupted .htaccess file and PHP memory limit.

    Can you please check if your .htaccess file is not changed by any way and not corrupted?

    Can you also please enable debugging by adding the following three lines in your wp-config.php file?

    // Turn debugging on
    define('WP_DEBUG', true);

    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);

    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);

    And, would you mind allowing support access so we can have a closer look at this?

    To enable support access you can follow this guide here:

    Moreover, can you please send me message with FTP access credentials through our secure contact form here:

    Subject: “Attn: Rupok”



    -FTP Host URL

    -Link back to this thread for reference

    -Any other relevant URLs

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me.

    Have a nice day. Cheers!


  • Adam Czajczyk
    • Support Gorilla

    Hello Tom!

    As Rupok is not on line at the moment, I let myself check your site. I hope you don’t mind it :slight_smile:

    I wasn’t able to find /wp-content/debug.log anywhere there so I assume you removed it, is that right? We’d really like to take a look at it.

    That said, could you please follow the steps below (in that order exactly)?

    1) Enable debugging again by adding following lines to your wp-config.php file:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    This will keep WordPress debugging enabled and write its output into /wp-content/debug.log file while preventing errors from being displayed on the front-end.

    2) While Error 500 is indeed one of most general and undefined errors and in case of WordPress is often caused by some plugins, we already know (thanks to recent conflict test that you run) which plugins are most likely causing it. I think then the reason here may be memory limit as it usually is. I checked your PHP settings and it allows usage of up to 256M of memory but this doesn’t mean that WP will be able to use that much. That said, please add one more line to your wp-config.php file:

    define('WP_MEMORY_LIMIT', '256M');

    3) Now please try to enable those troublesome plugins one-by-one until you get a 500 error again (please do not remove debug.log file) or hopefully all of them are up and running just fine.

    Let me know how it went please and if you still weren’t able to enable all those plugins and error kept coming up – please do not remove debug.log file from your server.

    Best regards,


  • tom
    • WPMU DEV Initiate

    THANK YOU very much for your support.

    I’m so sorry, all this was my fault, I don’t know how I’ve didn’t see it before but I had edited my wp-config under the line:

    /* That’s all, stop editing! Happy blogging. */

    That was this from the very beginning! :slight_smile:

    I’ve never seen such a great support as on this site.

    10 points for you!Haha!!

    (I also love your points system, that’s very motivating. Could you let me some points? :p haha)

    Have a nice day!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.