Error 500 when activating plugin

Why am I getting server error 500 when trying to activate the plugin??

  • Rupok

    Hi Vir Saini,

    So sorry for the inconvenience you are having. I'm running WP Smush Pro in my test site but I'm not getting any error like that. So I think, this is your server specific issue.

    Just to make sure no other plugin is conflicting, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide:

    If you find no plugin conflicting, can you please increasing the memory limit of your WordPress instance? To know how you can do that, you can check this guide:

    Moreover, can you please turn on debug mode in WordPress? That will give us the exact error behind this issue. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    Please let us know the result of your plugin conflict test and debut data. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.