Error 500 when updating a menu item protection rule

I set a protection rule on a menu item a while back, now I try to remove that protection and I get error 500. I show the issue in this video: http://youtu.be/WhEJZSWoNEE

I already gave you access to my wordpress site to speed things up.

The apache authentication is:
Username: Admin2947
Password: 24472820

  • Sajid

    Hi @Jose Vega! Hope you are doing good today :slight_smile:

    I logged in and at first I got the same 500 server error. Then I assigned a test membership to a page, then removed that membership and it seems to be working now. Then I again tried to drop membership on page shown in video and it worked this time too.

    500 internal server error is most mysterious error out there. It can be misconfiguration of server, memory limit and any plugin conflict. See more details on this page.
    http://pcsupport.about.com/od/findbyerrormessage/a/500servererror.htm

    Any way it seems to be a temporary problem and its working now. Let us know if you get this error again and we will take a close look.

    Cheers, Sajid

  • Jose Vega

    I followed your advice. I disabled all the network-wide and site plugins except membership, and enable the twenty fifteen theme. The issue is still there.

    My server configuration is fine, the htaccess file only has wordpress default rules and the apache authentication.

    The protection rules work fine on the pages section, but the issue appears when removing a menu item rule. This always happens.

    Right now I´m confident enough to think that the issue is on your plugin. Please have a look again and make sure you´re testing menu item rules > "miembros" menu, not page rules.

    In my tests I found that I can add a new membership rule to the menu item, I also get error 500 but at least the change is saved after refreshing. But removing rules is still not working.

  • Sajid

    Hi @Jose Vega! Hope you are doing good today :slight_smile:

    Thanks for providing more details.

    Can you please provide WordPress and FTP login credentials via our private contact form so we can take closer look and troubleshoot this error. Please send in these details in following format including all necessary details.

    Subject: "Attn: Sajid Javed"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :simple_smile:

    https://premium.wpmudev.org/contact/

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.