Error 500 with Snapshot Backup

I am trying to make a backup usng snapshot but keep on getting the following error:
I have another website on this same domain and was able to create a snapshot with no hassles.

Internal Server Error

The server encountered an internal error or
misconfiguration and was unable to complete
your request.

Please contact the server administrator at
webmaster@tvs-test.co.za to inform them of the time this error occurred,
and the actions you performed just before this error.

More information about this error may be available
in the server error log.

Additionally, a 500 Internal Server Error
error was encountered while trying to use an ErrorDocument to handle the request.

Apache mod_fcgid/2.3.9 Server at tvs-test.co.za Port 80

    Denitsa

    Hello Kevin,
    I hope you are having an amazing day and thanks for asking!

    Can you provide us with the server error log? If that's a no, please access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);

    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    The log will be saved to a debug.log file inside the "/wp-content" folder. Please save the file as a .txt and attach it to your next post.
    If the file's larger than 5MB you might need to upload it somewhere like Dropbox and share the link here.

    I tried making a snapshot of only WP core tables on your install and it went well. When I try making a snapshot of just your plugin or theme files, then I get the error you mention, along with an error in the console:

    Would you try disabling all your plugins reverting to a default theme and then trying again? If the backup proceeds, start enabling plugins one by one trying to make a backup in between. If it stops working, last plugin you activated is at fault.
    If all goes well, then enable your previous theme and try again.

    Keep us posted on the results!

    Warm regards,
    Denitsa