Error 504 during installation WPMU plugins

I have already installed many of your plugins on my site. But right when I try to install others I get error 504.
This shows up in error log:
[24-Nov-2017 16:54:52 UTC] WPMU DEV Upgrader error: UPG.01 - Project not installed.

  • James Morris
    • WordPress Enthusiast

    Hello Prince

    I hope you are well today.

    This issue has been flagged for our SLS Team (code experts) so that they can dig into this issue further for you. An update will be posted here as soon as more information is available. Thank you for your patience while we sort through this issue.

    Best regards,

    James Morris

    • Paul Kevin
      • Neo

      Hello Prince ,

      Hope you are well today. Did you migrate an already existing site to siteground? I see this error : Timeout waiting for output from CGI script /{installation-path}/wp-admin/admin-ajax.php, referer: https://{yoursiteurl}/wp-admin/network/admin.php?page=wpmudev-plugins

      Looks like the server configuration has a limit on how long scripts should run and larger files to install which take longer to download and install, timeout before they complete. The TimeOut value on your Web server should be set to 0 or something quite big.

      Warm Regards
      Paul Kevin

  • Prince
    • New Recruit

    no. It's a fresh Wordpress install on a fresh hosting account.
    The domain came from my other hosting account before though, but I've already deleted that site and pointed the DNS to the new hosting account.

    Should I contact a support from my hosting provider so they can extend the timeout value?
    If I do need to. It would be great if you can write here exactly what I need to ask them, then I'll copy and paste it. Sorry, I'm not too technical.

    • Paul Kevin
      • Neo

      Hey there Prince ,

      Hope you are well today. The timeout version should be something like this :
      TimeOut 600 or TimeOut 0 most likely they will go for the first value. If its set to 600 it needs to be a higher value. This is in the apache config file and should help fix the error "Timeout waiting for output from CGI script"

      Warm Regards
      Paul Kevin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.