Error 522 on Snapshot manual backup, even after PHP settings value changes...

I've been using Updraftplus as well as Snapshot Pro for backups as I'm getting a Multisite installation ready and I want to be able to revert back as I enable/disable plugins.

Updraftplus backups have been going smoothly. Snapshot started failing just now.
Original PHP settings on my A2Hosting servers were:
max_execution_time = 300
default_socket_timeout = 60
and it failed. I got the Aw Shucks error 522 message (Cloudflare timeout).

I've updated the .htaccess file to
max_execution_time = 600
default_socket_timeout = 600
and checked via wp-serverinfo to make sure those settings are used
and the manual backups still fail.

I'd rather keep my php settings as they were as UpdraftPlus was running nicely. Could you find out what the problem is, as well as find a way that Snapshot Pro works with limited settings, similar to UpdraftPlus? I'd rather use your services as they're all part of the package.

Here's the log file contents:
[Remote][2016-10-01 10:43:16][Warning] API connection to register-settings returned non-200: 400
[snapshot][2016-10-01 19:01:13][Info] Starting backup
[snapshot][2016-10-01 19:01:13][Info] Created the backup and added the queues
[Queue][2016-10-01 19:01:13][Notice] Fetching [250] files as chunk 1
[snapshot][2016-10-01 19:01:43][Info] Successfully processed backup files chunk
[Queue][2016-10-01 19:01:44][Notice] Fetching [250] files as chunk 2
[snapshot][2016-10-01 19:02:14][Info] Successfully processed backup files chunk
[Queue][2016-10-01 19:02:15][Notice] Fetching [250] files as chunk 3
[snapshot][2016-10-01 19:02:45][Info] Successfully processed backup files chunk
[Queue][2016-10-01 19:02:46][Notice] Fetching [250] files as chunk 4
[snapshot][2016-10-01 19:03:16][Info] Successfully processed backup files chunk

Thanks,
Chris

  • Adam Czajczyk
    • Support Gorilla

    Hello Chris,

    I hope you're well today and thank you for your question!

    I accessed and checked your site and I can confirm the issue. The error comes from CloudFlare and is caused by connection timing out. That basically means that CloudFlare doesn't get a response to request as fast as it would expect.

    This can be caused by various reasons but I'd start with "making requests smaller". The plugin is not sending files "one by one" to our servers but rather it sends a backup in "chunks". The smaller the request, the faster it is served and even though the entire backup may then take longer it could help here.

    That said, please add the following line to the "wp-config.php" file of your site:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);

    Make sure that this line is above the "/* That's all, stop editing! */" line. Also please make sure that before adding it you deactivated scheduled backups. Then, after adding the line, give the "manual" backup another try and let me know if that worked. You can then re-activate scheduled backups as well.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.