Error Accessing Blogs menu

I have a fresh install of wordpress 3.01, with buddypress 1.2.5.1 activated and also activated bp-daily-child theme (just downloaded)

I go to Blogs menu and get error

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'bp_blogs_visit_blog_button' was given in /home2/mainsite/public_html/wpsite/wp-includes/plugin.php on line

I haven't installed any plugins at all.

These are the repeated errors in server log...

[Sat Oct 30 16:56:37 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:37 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:38 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:39 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:40 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:41 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:41 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:41 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring! [Sat Oct 30 16:56:42 2010] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!

I am not able to provide a link to the site per customer's request.

Thanks for help