Error activating Anti-Blog 1.0.6

I upgraded to WordPress 3.1 and Buddy Press 1.2.8. Every thing went find except a few plugins not working. WordPress Dev SEO I mention in a previous post and now Anti-Splog

For some reason Anti-Splog 1.0.6 isn't recognizing that I'm running WordPress 3.1 Odd, but I'm sure you'll find an easy fix. Below is the error message when trying to Network Activate the plugin

Plugin could not be activated because it triggered a fatal error.
This version of Anti-Splog is only compatible with WordPress 3.1 and greater.