Error after install: parse_url expects 1 parameter, gets 2

I own a WordPress 3.1.3 site that is hosted on one of the large hosting companies that advertises on television a lot. I've been using Ultimate SEO for an SEO solution for a while and it's worked well. Having recently bought a membership to WPMU Dev, I thought I'd try yours out.

I installed the plug-in and activated it. When I click on the link or any of the tabs for it, I get a mostly-blank screen with the error:

Warning: parse_url() expects exactly 1 parameter, 2 given in <snip>/wp-content/plugins/wpmu-dev-seo/wds-files/wds-sitemaps/wds-sitemaps.php on line 448

Thinking that maybe it was an incompatibility with some other plug-in installed on the site, I deactivated all of them such that WPMU DEV SEO is the only one currently active. The error has continued.

Any help would be appreciated.