Error after installing plugins pop up!

Hi there,
I tried to download the plugins pop up! from WPMU DV but I was wrong.
I manually download and install by FTP, but now I get the following error on my front page:

Strict Standards: Static function Popover_Rules_Rule::add() should not be abstract in /homepages/21/d530477929/htdocs/web/wp-content/plugins/popover/popoverincludes/includes/functions.php on line 447