error code after activating....

Hi,

What should I do after this error code?

Thanks!

  • mpress

    The english code: This code appears when trying to include recent posts within a widget.

    Notice: Undefined index: title in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 65
    
    Notice: Undefined index: post_type in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 66
    
    Notice: Undefined index: featured_image in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 67
    
    Notice: Undefined index: post_author in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 68
    
    Notice: Undefined index: limit in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 69
    
    Notice: Undefined index: class in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 70
    
    Notice: Undefined index: order_by in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 71
    
    Notice: Undefined index: order_dir in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 72
    
    Notice: Undefined index: show_body in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 77
    
    Notice: Undefined index: show_thumbs in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 78
    
    Notice: Undefined index: show_dates in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 79
    
    Notice: Undefined index: fields in /storage/web/public/sites/proexample.h4-business-support.com/wp-content/plugins/recent_custom_post_type/recent-custom-post-type.php on line 81
  • Tyler Postle

    Hey mpress,

    Hope you're doing well today! Thanks for reporting this. I get the same on my install and I've notified the developer :slight_smile:

    Is your site still in development? It looks like you have wp_debug set to 'true' in your wp-config.php file, if you change that to 'false' then you won't see those notices. They are harmless for the most part, but should still get fixed up to not cause any issues in the future.

    wp_debug should always be set to 'false' on a live site.

    You can find more info on it here: http://codex.wordpress.org/WP_DEBUG

    If you still want to see the errors then you can use the debug log like this:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    With those constants, now you have the debug log still true, but it won't display the notices on the frontend and instead displays them in the log, which will be located:

    /wp-content/debug.log

    Hope this helps!

    Let us know if you have any further questions in the meantime.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.