Error Connecting to Database

Hi,
I'm getting the dreaded "Error connecting to Database" on an otherwise blank white screen.
I read through a couple of articles on fixing the problem and in doing so, added the line:
define('WP_ALLOW_REPAIR', true); to my wp-config.php file.
When WP tried to repair and optimize the database, I got quite a few scary looking error messages regarding tables not being closed properly. The result of the database check can be found here:
Can you help me resolve it and tell me what I did wrong to cause it? All I remember doing before this error showed up is deleting some unnecessary plugins. In my internet searches it looks like the "Error connecting to Database" is a pretty common problem. It's got all of my sites down on my server, even non-WP sites. So if this occurs when I actually have Users, I'll need to know how to fix it pronto!!
Thanks guys!!
m

  • Nithin

    Hi Hitt-Girl,

    Hope you are doing good today. :slight_smile:

    When WP tried to repair and optimize the database, I got quite a few scary looking error messages regarding tables not being closed properly. The result of the database check can be found here:

    I don't see any result this is what I see at the moment, have you fixed it?

    As you have mentioned Error connecting to Database is quite common, and one of the major reasons would be your host being down temporarily, have you fixed the current issue, or is this what happened here?

    Since you did say that your non-WP sites were down, I would say that this seems to be related to your host, please confirm whether this is the case, if not please do let us know, we would be glad to help get you sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Hitt-Girl

    Hi Nithin,
    Thanks for your reply.
    I'm not sure what's going on. Sometimes everything is fine, and then other times I get an error message. I do notice the error when I delete some plugins or themes. I've even had the guys at my server monitoring service go in and check. They say the servers up and running fine and MySQL looks okay. But I still got the white screen.
    So as a last resort, I ran a backup with the decision to just start over from last week. Which is fine, since I don't have any Users yet. But, I'm still getting intermittent Database errors? :slight_frown:
    For example just now, everything looked fine so I started to delete/add/update plugins like I was doing before all this happened. I just went in to update the MailChimp Sync plugin and its just hanging there.
    It's a non-managed VPS, so the host is...me? I guess? Short of deleting everything and starting over, I'm not sure what to do--but starting over from scratch is literally my answer to every problem lol. I'm sure there's a better way to figure this out (and prevent it) without going to such extremes?
    Thanks again,
    m

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.