error: Domainmapping failed because the domainmap plugin is not activated!

Hi,

We’re using WordPress 3.1.3

We recently bought your new blog templates plugin, but everytime we receive following error:

Domainmapping failed because the domainmap plugin is not activated!

Then we have to manually change the site info’s of all new created clone url’s.

How to solve this problem?

We also installed this domainmapping plugin: http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

but doesn’t work either.

Thanks

Erik

  • Mason
    • DEV MAN’s Sidekick

    Hiya Erik,

    Have you implemented domain mapping on your template site? I wouldn’t recommend doing that. I’ll ask the devs to take a look, but if you’ve got an entry for domain mapping on the template site I’d recommend removing it.

    Thanks!

  • berlok
    • WPMU DEV Initiate

    Hi,

    Sorry don’t understand what you mean with: “implemented domain mapping on your template site”

    We use the suffusion theme from aquoid themes.

    With or without the domainmapping plugin mentioned before we receive this error.

    If the problem remains, perhaps we can get a little help how to change all ready created domains thru phpmyadmin. How should the mysql code look like to replace the wrong url with correct url (both in table site as in table used for file upload).

    Thanks

    Erik

  • berlok
    • WPMU DEV Initiate

    Hi again,

    Very very very strange……

    First it didn’t work without the domainmapping plugin, then we installed the plugin and still error.

    Now we deactivate the plugin and it is working……???

    anyway, i’m happy it is working now :wink:

    Thanks

    Erik

  • Mason
    • DEV MAN’s Sidekick

    Hiya Erik,

    It sounds like you may have something incorrect in your initial configuration.

    Check to make sure that the domain defined in your wp-config.php file is the same (domain_current_site) like this:

    example.com (no ‘http’ or ‘www’:wink:

    Then look in your database at the wp_site table and make sure it is exactly the same for domain:

    example.com and that the ‘path’ is a backslash /

    Finally check the home and siteurl values in your wp_options database:

    home: http://example.com

    siteurl: http://example.com

    My hunch is that this is setup incorrectly in one of these places. Thanks!

  • berlok
    • WPMU DEV Initiate

    Hi Mason,

    Indeed in the wp-config and in wp_site table the url was with www. in front.

    But if we try to change the wp_options settings, then the site is not working anymore.

    The error remains.

    Perhaps we need to use url.com as a template, instead of template.url.com ??

    Thanks,

    Erik

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Indeed in the wp-config and in wp_site table the url was with www. in front

    That should be ok. As long as they match.

    Can I get a couple URLs to look at? I’m still not totally clear on what is happening. The site you have setup to be the ‘template’ site. Can I have a link to that one? It’d really help to see what you’re seeing. Maybe screenshots if not?

    Also, have a look at your php error logs and see if anything is popping up there.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.